summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2024-02-14 15:25:57 -0500
committerKevin MacMartin2024-02-14 15:25:57 -0500
commit83bee250555d57da46345ddeea3a4c21164d6f8a (patch)
tree5f700b4c7df52114912a9529f589244ec9c19ce5
parenta3985ef4f3874ddea7d83fda3d0e85c9253cf71d (diff)
downloadaur-83bee250555d57da46345ddeea3a4c21164d6f8a.tar.gz
Use native electron instead of the packaged one, and trim out the unnecessary files and dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD39
-rw-r--r--upscayl5
3 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59a0e5993676..2205be04ebb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = upscayl-bin
pkgdesc = Free and Open Source AI Image Upscaler
pkgver = 2.9.9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/upscayl/upscayl
arch = x86_64
license = AGPL3
makedepends = unzip
- depends = libasound.so
- depends = gtk3
depends = libvips
- depends = nodejs
- depends = nss
depends = openjpeg2
+ depends = electron
provides = upscayl
conflicts = upscayl
noextract = upscayl-2.9.9-linux.zip
options = !strip
source = https://github.com/upscayl/upscayl/releases/download/v2.9.9/upscayl-2.9.9-linux.zip
+ source = upscayl
sha512sums = 06f4a4439cbd7df9dba151530a42368f08d0fab5b145c1563a080aac1aac4b4a094a135f76b381b6a94a7d66d1071dccc647e9c69912cacfe3fe3157a211bf1c
+ sha512sums = eae35fb7bef2b50512dec60fe1ab9e5bb7f4cd71931bd36951ee30a2d238299aeab88bac35aba4108ddd5c3e2cf6948a9cd144b0f3451e30c4f28b81d2e1e07a
pkgname = upscayl-bin
diff --git a/PKGBUILD b/PKGBUILD
index 03a1a992f089..aa2ccedf98f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,44 +6,49 @@
_pkgname=upscayl
pkgname=$_pkgname-bin
pkgver=2.9.9
-pkgrel=2
+pkgrel=3
pkgdesc='Free and Open Source AI Image Upscaler'
url='https://github.com/upscayl/upscayl'
license=('AGPL3')
arch=('x86_64')
-depends=('libasound.so' 'gtk3' 'libvips' 'nodejs' 'nss' 'openjpeg2')
+depends=('libvips' 'openjpeg2' 'electron')
makedepends=('unzip')
provides=($_pkgname)
conflicts=($_pkgname)
options=('!strip')
noextract=("upscayl-${pkgver}-linux.zip")
-source=("https://github.com/upscayl/upscayl/releases/download/v${pkgver}/upscayl-${pkgver}-linux.zip")
-sha512sums=('06f4a4439cbd7df9dba151530a42368f08d0fab5b145c1563a080aac1aac4b4a094a135f76b381b6a94a7d66d1071dccc647e9c69912cacfe3fe3157a211bf1c')
+
+source=(
+ "https://github.com/upscayl/upscayl/releases/download/v${pkgver}/upscayl-${pkgver}-linux.zip"
+ "$_pkgname"
+)
+
+sha512sums=(
+ '06f4a4439cbd7df9dba151530a42368f08d0fab5b145c1563a080aac1aac4b4a094a135f76b381b6a94a7d66d1071dccc647e9c69912cacfe3fe3157a211bf1c'
+ 'eae35fb7bef2b50512dec60fe1ab9e5bb7f4cd71931bd36951ee30a2d238299aeab88bac35aba4108ddd5c3e2cf6948a9cd144b0f3451e30c4f28b81d2e1e07a'
+)
prepare() {
cd "$srcdir"
- unzip upscayl-${pkgver}-linux.zip -x resources/128x128.png -d upscayl
- printf '%s\n' 'Icon=org.upscayl.Upscayl' >> "$_pkgname"/resources/org.upscayl.Upscayl.desktop
+ unzip ${_pkgname}-${pkgver}-linux.zip -x resources/128x128.png -d ${_pkgname}-${pkgver}
+ printf '%s\n' 'Icon=org.upscayl.Upscayl' >> ${_pkgname}-${pkgver}/resources/org.upscayl.Upscayl.desktop
}
package() {
cd "$srcdir"
- # Licenses
- install -dm755 "$pkgdir"/usr/share/licenses/$pkgname
- mv "$_pkgname"/LICENSE* "$pkgdir"/usr/share/licenses/$pkgname/
+ # Launcher
+ install -Dm755 "$_pkgname" "$pkgdir"/usr/bin/$_pkgname
+
+ cd ${_pkgname}-${pkgver}/resources
# XDG Launcher
install -dm755 "$pkgdir"/usr/share/applications
install -dm755 "$pkgdir"/usr/share/pixmaps
- mv "$_pkgname"/resources/org.upscayl.Upscayl.desktop "$pkgdir"/usr/share/applications/
- mv "$_pkgname"/resources/512x512.png "$pkgdir"/usr/share/pixmaps/org.upscayl.Upscayl.png
+ mv org.upscayl.Upscayl.desktop "$pkgdir"/usr/share/applications/
+ mv 512x512.png "$pkgdir"/usr/share/pixmaps/org.upscayl.Upscayl.png
# App directory
- install -dm755 "$pkgdir"/opt
- mv "$_pkgname" "$pkgdir"/opt/
-
- # Symlink in $PATH
- install -dm755 "$pkgdir/usr/bin"
- ln -s /opt/$_pkgname/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -dm755 "$pkgdir"/opt/$_pkgname
+ mv * "$pkgdir"/opt/${_pkgname}/
}
diff --git a/upscayl b/upscayl
new file mode 100644
index 000000000000..12482e418ba4
--- /dev/null
+++ b/upscayl
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+export ELECTRON_IS_DEV=0
+
+electron /opt/upscayl/app.asar "$@"