summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2019-08-19 09:42:40 +0200
committerDanilo Bargen2019-08-19 09:44:24 +0200
commit7023cc0af526afd3d8498326484be030731b7068 (patch)
tree1564461058984b47c2b98ee3c16e0c58788454b6
parentf77218499acb66a984c480de6ad5bd971da2d90c (diff)
downloadaur-7023cc0af526afd3d8498326484be030731b7068.tar.gz
Version 1.0.0-1
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD41
3 files changed, 36 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5136a50c51a2..90b6d104c961 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
# Generated by mksrcinfo v8
-# Wed Aug 8 07:42:50 UTC 2018
+# Mon Aug 19 07:44:17 UTC 2019
pkgbase = upscrot
- pkgdesc = Take a screenshot using the Linux scrot command and upload it directly to your SSH server.
- pkgver = 1.0.0b2
- pkgrel = 2
+ pkgdesc = Take a screenshot using the Linux scrot command and upload it to your SSH server.
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/dbrgn/upscrot
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
makedepends = python
makedepends = python-setuptools
- makedepends = python-pip
depends = python
depends = python-appdirs
depends = scrot
- provides = upscrot
- conflicts = upscrot
- noextract = upscrot-1.0.0b2-py3-none-any.whl
- source = https://pypi.python.org/packages/py3/u/upscrot/upscrot-1.0.0b2-py3-none-any.whl
- sha256sums = d04b88f7fc7e93b0a49e5a76d0c4c2f60fad2a943de25d605046f2993680a801
+ source = https://files.pythonhosted.org/packages/source/u/upscrot/upscrot-1.0.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/u/upscrot/upscrot-1.0.0.tar.gz.asc
+ sha256sums = 7343be1d8be132d7410fc57dfa22cb980bfce871b1fd3b65da2d4d81972f2749
+ sha256sums = SKIP
pkgname = upscrot
diff --git a/.gitignore b/.gitignore
index f56ba6753183..f00377fe5cad 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,6 @@
pkg/
src/
*.whl
+*.tar.gz
*.tar.xz
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
index cfa5ed346083..1e694115345e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
# Maintainer: Danilo Bargen aur ât dbrgn döt ch
+# PGP key is on keyservers and at https://keybase.io/dbrgn
pkgname=upscrot
-pkgver=1.0.0b2
-pkgrel=2
-_wheel="${pkgname}-${pkgver}-py3-none-any.whl"
-pkgdesc="Take a screenshot using the Linux scrot command and upload it directly to your SSH server."
-arch=('i686' 'x86_64')
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Take a screenshot using the Linux scrot command and upload it to your SSH server."
+arch=('any')
url="https://github.com/dbrgn/$pkgname"
license=('GPL')
-makedepends=('python' 'python-setuptools' 'python-pip')
-depends=('python'
- 'python-appdirs'
- 'scrot')
-provides=('upscrot')
-conflicts=('upscrot')
-noextract=(${_wheel})
-source=("https://pypi.python.org/packages/py3/u/${pkgname}/${_wheel}")
-sha256sums=('d04b88f7fc7e93b0a49e5a76d0c4c2f60fad2a943de25d605046f2993680a801')
+makedepends=('python' 'python-setuptools')
+depends=('python' 'python-appdirs' 'scrot')
+source=(
+ "https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz.asc"
+)
+sha256sums=(
+ '7343be1d8be132d7410fc57dfa22cb980bfce871b1fd3b65da2d4d81972f2749'
+ 'SKIP'
+)
+validpgpkeys=('EA456E8BAF0109429583EED83578F667F2F3A5FA')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ python setup.py build
+}
package() {
- cd "$srcdir"
- pip install --no-deps --no-warn-script-location --root "$pkgdir" $_wheel
+ cd "$srcdir/$pkgname-$pkgver/"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
+
+# vim:set ts=2 sw=2 et: