summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Henrik Bruhn2020-12-08 14:14:03 +0100
committerJan-Henrik Bruhn2020-12-08 14:15:07 +0100
commit8305c15386946b1421ccb4639a0a925ebc99da4c (patch)
treea2f1e523c933059478792113df7a79d47892c023
downloadaur-8305c15386946b1421ccb4639a0a925ebc99da4c.tar.gz
Initial version
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD42
-rwxr-xr-xradicle-launcher.sh2
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a096c243863
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = upstream-electron-bin
+ pkgdesc = Desktop client for radicle (binary version, system electron)
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/radicle-dev/radicle-upstream
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = electron
+ provides = upstream
+ conflicts = radicle
+ conflicts = upstream
+ source = https://releases.radicle.xyz/radicle-upstream-0.1.4.AppImage
+ source = https://raw.githubusercontent.com/radicle-dev/radicle-upstream/v0.1.4/LICENSE
+ source = radicle-launcher.sh
+ sha256sums = 267a567b851c9ec301b0cad517eb1a1fdaf3ed46bf85a85000285b066185c5c6
+ sha256sums = d1bb5e1a4cd3774790ae7024904d572c27267857ed004a062416d520bf4230ad
+ sha256sums = ca84ffe5cda88ad75fa3aa95c9f100768eff2ea91b977235418ef74ec1f37ac4
+
+pkgname = upstream-electron-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..55614395edb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.*
+*.AppImage
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e6dd4899a52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jan-Henrik Bruhn <aur@jhbruhn.de>
+pkgname=upstream-electron-bin
+pkgver=0.1.4
+pkgrel=1
+pkgdesc='Desktop client for radicle (binary version, system electron)'
+arch=('x86_64')
+url='https://github.com/radicle-dev/radicle-upstream'
+license=('GPL' 'custom')
+provides=('upstream')
+conflicts=('radicle' 'upstream')
+depends=('electron')
+_package="radicle-upstream-${pkgver}.AppImage"
+source=(
+ "https://releases.radicle.xyz/${_package}"
+ "https://raw.githubusercontent.com/radicle-dev/radicle-upstream/v${pkgver}/LICENSE"
+ "radicle-launcher.sh"
+)
+sha256sums=('267a567b851c9ec301b0cad517eb1a1fdaf3ed46bf85a85000285b066185c5c6'
+ 'd1bb5e1a4cd3774790ae7024904d572c27267857ed004a062416d520bf4230ad'
+ 'ca84ffe5cda88ad75fa3aa95c9f100768eff2ea91b977235418ef74ec1f37ac4')
+
+package() {
+ chmod +x "${srcdir}/${_package}"
+ `${srcdir}/${_package} --appimage-extract &>/dev/null`
+ rm -rf "${srcdir}/upstream"
+ mv "${srcdir}/squashfs-root" "${srcdir}/upstream"
+
+ install -d -m755 "${pkgdir}/opt/"
+ cp -a "${srcdir}/upstream/." "${pkgdir}/opt/upstream/"
+ find "${pkgdir}/opt/upstream/" -type d -exec chmod 755 {} +
+ chmod +rx "${pkgdir}/opt/upstream/radicle-upstream"
+
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/radicle-launcher.sh" "${pkgdir}/usr/bin/upstream"
+
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -Dm644 "${srcdir}/upstream/usr/share/icons/hicolor/0x0/apps/radicle-upstream.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/radicle-upstream.png"
+ install -Dm644 "${srcdir}/upstream/radicle-upstream.desktop" "${pkgdir}/usr/share/applications/radicle-upstream.desktop"
+ sed -e "s/AppRun/upstream/g" -i "${pkgdir}/usr/share/applications/radicle-upstream.desktop"
+}
+
diff --git a/radicle-launcher.sh b/radicle-launcher.sh
new file mode 100755
index 000000000000..d0479f7d4683
--- /dev/null
+++ b/radicle-launcher.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/electron /opt/upstream/resources/app.asar "$@"