summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaksym2018-05-04 21:49:22 +0300
committerMaksym2018-05-04 21:49:22 +0300
commitfe8ab581816e55466140af1468013f2ddbd4114d (patch)
tree6db65295d14f5dcb5ec0d86fc70a2a732d712dae
parent960354cc4df8e479047a333528fe0d6d8d8d9c05 (diff)
downloadaur-fe8ab581816e55466140af1468013f2ddbd4114d.tar.gz
Updated to upstream version 5.1.0.509.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
-rw-r--r--upwork.install4
3 files changed, 21 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13f8d2f1abfd..45796b491867 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,28 @@
# Generated by mksrcinfo v8
-# Fri Feb 9 15:05:45 UTC 2018
+# Fri May 4 18:48:17 UTC 2018
pkgbase = upwork
- pkgdesc = Desktop App (aka Team App) Standard version
- pkgver = 4.2.153.0
- pkgrel = 4
+ pkgdesc = Desktop App Standard version
+ pkgver = 5.1.0.509
+ pkgrel = 1
url = https://www.upwork.com/downloads?source=Footer
install = upwork.install
arch = x86_64
license = custom
- makedepends = git
- makedepends = gtk-doc
depends = alsa-lib
depends = gconf
- depends = gtkglext
- depends = libgcrypt15
+ depends = gdk-pixbuf2
+ depends = gtk2
depends = libxss
depends = libxtst
depends = nss
conflicts = upwork-alpha
conflicts = upwork-appimage
+ conflicts = upwork-latest
conflicts = upwork-beta
source = LICENSE
- source = git+https://git.gnome.org/browse/pango#commit=6c5d1d35061a91c3c0792f7720da3f8308ebff65
md5sums = bb535c74d4673cee6437b04d33b32138
- md5sums = SKIP
- source_x86_64 = upwork_amd64_4.2.153.0.deb::https://updates-desktopapp.upwork.com/binaries/v4_2_153_0_tkzkho5lhz15j08q/upwork_amd64.deb
- md5sums_x86_64 = 6c33e3ff5ae168c840f46887d690fd5e
+ source_x86_64 = https://updates-desktopapp.upwork.com/binaries/v5_1_0_509_87zq7fllb6sf8y49/upwork_5.1.0.509_amd64.deb
+ md5sums_x86_64 = e9701690c32a84ceaf1e93a104471040
pkgname = upwork
diff --git a/PKGBUILD b/PKGBUILD
index 4dbac098e54e..a39fde246a42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,58 +2,32 @@
# Maintainer: Maksym Sheremet <msheremet at sheremets dot com>
pkgname=upwork
-pkgver=4.2.153.0
+pkgver=5.1.0.509
_rawver=${pkgver//./_}
-_hashver="tkzkho5lhz15j08q"
-pkgrel=4
-pkgdesc="Desktop App (aka Team App) Standard version"
+_hashver="87zq7fllb6sf8y49"
+pkgrel=1
+pkgdesc="Desktop App Standard version"
arch=('x86_64')
url="https://www.upwork.com/downloads?source=Footer"
license=('custom')
-conflicts=('upwork-alpha' 'upwork-appimage' 'upwork-beta')
-depends=('alsa-lib' 'gconf' 'gtkglext' 'libgcrypt15' 'libxss' 'libxtst' 'nss')
-makedepends=('git' 'gtk-doc') # needed to build pango
+conflicts=('upwork-alpha' 'upwork-appimage' 'upwork-latest' 'upwork-beta')
+depends=('alsa-lib' 'gconf' 'gdk-pixbuf2' 'gtk2' 'libxss' 'libxtst' 'nss')
install=upwork.install
-source=("LICENSE" "git+https://git.gnome.org/browse/pango#commit=6c5d1d35061a91c3c0792f7720da3f8308ebff65")
-md5sums=('bb535c74d4673cee6437b04d33b32138' 'SKIP')
-#md5sums_i686=('fa3aa945068e49081e1ac2cc7490032b')
-md5sums_x86_64=('6c33e3ff5ae168c840f46887d690fd5e')
-# how to get links Standard, Beta, Alpha: grep "https://updates-desktopapp.upwork.com/binaries" ~/.Upwork/Upwork/Logs/* | tail -n 4
-source_x86_64=(upwork_amd64_${pkgver}.deb::https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_amd64.deb)
-#source_i686=(upwork_i386_${pkgver}.deb::https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_i386.deb)
+source=("LICENSE")
+md5sums=('bb535c74d4673cee6437b04d33b32138')
+md5sums_x86_64=('e9701690c32a84ceaf1e93a104471040')
+# how to get links Standard, Beta, Alpha: grep -A3 "checkUpdateFromServerSucess" ~/.Upwork/Upwork/Logs/* | tail -n 4
+source_x86_64=(https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_${pkgver}_amd64.deb)
prepare() {
cd "${srcdir}"
- tar -zxf "${srcdir}/data.tar.gz"
-### BEGIN pango section ###
- cd pango
- NOCONFIGURE=1 ./autogen.sh
-### END pango section ###
+ tar -xJf "${srcdir}/data.tar.xz"
}
-### BEGIN pango section ###
-build() {
- cd "${srcdir}/pango"
- ./configure --prefix=/usr
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
-}
-
-check() {
- cd "${srcdir}/pango"
- make -k check || :
-}
-### END pango section ###
-
package() {
cd "${srcdir}"
cp -rp usr "${pkgdir}/usr"
install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-### BEGIN pango section ###
- install -Dm755 "${srcdir}/pango/pango/.libs/libpangoft2-1.0.so.0.4000.5" \
- "${pkgdir}/usr/share/upwork/libpangoft2-1.0.so.0.4000.5"
- ln -s "libpangoft2-1.0.so.0.4000.5" "${pkgdir}/usr/share/upwork/libpangoft2-1.0.so.0"
-### END pango section ###
}
diff --git a/upwork.install b/upwork.install
index 23882f0c900a..1d15e5ac1539 100644
--- a/upwork.install
+++ b/upwork.install
@@ -1,8 +1,5 @@
post_install() {
xdg-icon-resource forceupdate
-# mkdir -p /var/lib/Upwork/upwork
-# chmod 777 /var/lib/Upwork/upwork
-# chmod 4755 /usr/share/upwork/chrome-sandbox
}
post_upgrade() {
@@ -11,5 +8,4 @@ post_upgrade() {
post_remove() {
xdg-icon-resource forceupdate
-# rm -R /var/lib/Upwork
}