summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYokai Shogun2021-09-02 21:01:06 -0400
committerYokai Shogun2021-09-02 21:01:06 -0400
commit50ac608d9c74c35ba4e092cb38dac0fb00d28cc5 (patch)
tree8224f717983a361bfb8554692e609589cff7be74
downloadaur-50ac608d9c74c35ba4e092cb38dac0fb00d28cc5.tar.gz
initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD64
-rw-r--r--config.state15
-rw-r--r--fix_userdir_location.diff16
-rw-r--r--uqm-megamod4
-rw-r--r--uqm-megamod.desktop9
-rw-r--r--uqm-megamod.pngbin0 -> 125699 bytes
7 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..079c784ca826
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = uqm-megamod
+ pkgdesc = A fork of The Ur-Quan Masters that remasters the HD mod with a veritable smorgasbord of extra features and options by Serosis.
+ pkgver = 0.8.0.85
+ pkgrel = 1
+ url = https://github.com/Serosis/UQM-MegaMod
+ arch = x86_64
+ license = GPL2
+ depends = libogg
+ depends = libpng
+ depends = libvorbis
+ depends = libgl
+ depends = sdl2
+ depends = zlib
+ depends = glu
+ depends = libmikmod
+ depends = lua52
+ depends = uqm-megamod-data
+ optdepends = uqm-megamod-addon-hd: For HD assets
+ optdepends = uqm-megamod-addon-3do: For 3DO content (voice, music and videos)
+ noextract = mm-0.8.0.85-content.uqm
+ source = uqm-megamod-0.8.0.85.tar.gz::https://github.com/Serosis/UQM-MegaMod/archive/refs/tags/0.8.0.85.tar.gz
+ source = config.state
+ source = uqm-megamod
+ source = uqm-megamod.desktop
+ source = uqm-megamod.png
+ source = fix_userdir_location.diff
+ md5sums = f532e3e3eda56215611d4aa988035924
+ md5sums = b0387306700c3c853b13876fa13e45fd
+ md5sums = 123544d70ae98cb3037f9595cc427b72
+ md5sums = 16019d6775329f5d4a57f9280b4559f1
+ md5sums = c6a3026f3a42c24f47d9ceacf86d1d83
+ md5sums = fb5dccf94645bafb023ba2117a33ac70
+
+pkgname = uqm-megamod
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19848c834f37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer : Victor Savcenco <victor dot sav at linux dot com>
+
+pkgname=uqm-megamod
+pkgver=0.8.0.85
+pkgrel=1
+pkgdesc="A fork of The Ur-Quan Masters that remasters the HD mod with a veritable smorgasbord of extra features and options by Serosis."
+arch=("x86_64")
+url="https://github.com/Serosis/UQM-MegaMod"
+license=("GPL2")
+
+depends=("libogg" "libpng" "libvorbis" "libgl" "sdl2" "zlib" "glu" "libmikmod" "lua52" "uqm-megamod-data")
+optdepends=(
+ "uqm-megamod-addon-hd: For HD assets"
+ "uqm-megamod-addon-3do: For 3DO content (voice, music and videos)"
+)
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/Serosis/UQM-MegaMod/archive/refs/tags/${pkgver}.tar.gz"
+ config.state
+ uqm-megamod
+ uqm-megamod.desktop
+ uqm-megamod.png
+ fix_userdir_location.diff
+)
+
+md5sums=(
+ "f532e3e3eda56215611d4aa988035924"
+ "b0387306700c3c853b13876fa13e45fd"
+ "123544d70ae98cb3037f9595cc427b72"
+ "16019d6775329f5d4a57f9280b4559f1"
+ "c6a3026f3a42c24f47d9ceacf86d1d83"
+ "fb5dccf94645bafb023ba2117a33ac70"
+)
+
+noextract=("mm-${pkgver}-content.uqm")
+
+prepare() {
+ mv "${srcdir}/UQM-MegaMod-${pkgver}" "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cp "${srcdir}/config.state" .
+ patch -p1 < "${srcdir}/fix_userdir_location.diff"
+ sed -i 's/uqm_CFLAGS="$uqm_CFLAGS -Isrc"/uqm_CFLAGS="$CPPFLAGS $CFLAGS $uqm_CFLAGS -Isrc"/' Makeproject
+ sed -i 's/uqm_CXXFLAGS="$uqm_CXXFLAGS -Isrc"/uqm_CXXFLAGS="$CPPFLAGS $CXXFLAGS $uqm_CXXFLAGS -Isrc"\nuqm_LDFLAGS="$LDFLAGS $uqm_LDFLAGS"/' Makeproject
+
+ ./build.sh uqm reprocess_config
+}
+
+build() {
+ CFLAGS+=" $(pkgconf --cflags lua52) $(pkgconf --cflags libmikmod)"
+ LDFLAGS+=" $(pkgconf --libs lua52) $(pkgconf --libs libmikmod)"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./build.sh uqm
+}
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}/UrQuanMasters" "${pkgdir}/usr/lib/uqm/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ mkdir -p "${pkgdir}/usr/share/doc" "${pkgdir}/usr/share/licenses"
+ cp -r "${srcdir}/${pkgname}-$pkgver/doc" "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-$pkgver/licenses" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/config.state b/config.state
new file mode 100644
index 000000000000..7ed6158f2a1e
--- /dev/null
+++ b/config.state
@@ -0,0 +1,15 @@
+CHOICE_debug_VALUE='nodebug'
+CHOICE_graphics_VALUE='sdl2'
+CHOICE_sound_VALUE='mixsdl'
+CHOICE_mikmod_VALUE='external'
+CHOICE_lua_VALUE='external'
+CHOICE_ovcodec_VALUE='standard'
+CHOICE_netplay_VALUE='full'
+CHOICE_joystick_VALUE='enabled'
+CHOICE_ioformat_VALUE='stdio_zip'
+CHOICE_accel_VALUE='asm'
+CHOICE_threadlib_VALUE='sdl'
+INPUT_install_prefix_VALUE='@install_prefix@'
+INPUT_install_bindir_VALUE='$prefix/bin'
+INPUT_install_libdir_VALUE='$prefix/lib'
+INPUT_install_sharedir_VALUE='$prefix/share'
diff --git a/fix_userdir_location.diff b/fix_userdir_location.diff
new file mode 100644
index 000000000000..be5e3c72564d
--- /dev/null
+++ b/fix_userdir_location.diff
@@ -0,0 +1,16 @@
+diff '--color=auto' -Naur UQM-MegaMod-0.8.0.85/src/config_unix.h.in UQM-MegaMod-0.8.0.85_fix/src/config_unix.h.in
+--- UQM-MegaMod-0.8.0.85/src/config_unix.h.in 2020-11-05 20:46:36.000000000 -0500
++++ UQM-MegaMod-0.8.0.85_fix/src/config_unix.h.in 2021-09-01 23:10:32.505028630 -0400
+@@ -11,10 +11,10 @@
+ #define CONFIG_UNIX_H_
+
+ /* Directory where the UQM game data is located */
+-#define CONTENTDIR "@CONTENTDIR@"
++#define CONTENTDIR "/usr/share/uqm-megamod"
+
+ /* Directory where game data will be stored */
+-#define USERDIR "~/.uqm-megamod/"
++#define USERDIR "~/.local/share/uqm-megamod/"
+
+ /* Directory where config files will be stored */
+ #define CONFIGDIR USERDIR
diff --git a/uqm-megamod b/uqm-megamod
new file mode 100644
index 000000000000..f8bac1bf45c5
--- /dev/null
+++ b/uqm-megamod
@@ -0,0 +1,4 @@
+#!/usr/bin/env sh
+
+exec "/usr/lib/uqm/uqm-megamod" "--contentdir=/usr/share/uqm-megamod/content" "$@"
+
diff --git a/uqm-megamod.desktop b/uqm-megamod.desktop
new file mode 100644
index 000000000000..0fca82765db2
--- /dev/null
+++ b/uqm-megamod.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=The Ur-Quan Masters Megamod
+Comment=Oh God...Please don't let me die today! Tomorrow would be so much better!
+Exec=uqm-megamod
+Icon=uqm-megamod
+Terminal=false
+Type=Application
+Encoding=UTF-8
+Categories=Application;Game;ArcadeGame;StrategyGame;
diff --git a/uqm-megamod.png b/uqm-megamod.png
new file mode 100644
index 000000000000..5426b1e3c7c5
--- /dev/null
+++ b/uqm-megamod.png
Binary files differ