summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYokai Shogun2021-09-02 21:06:53 -0400
committerYokai Shogun2021-09-02 21:06:53 -0400
commit6fa67ed84872a13d2289af548b3c76374ccc21b4 (patch)
tree473f821282abffb3d16408e0beec52c71fe8c2fd
downloadaur-6fa67ed84872a13d2289af548b3c76374ccc21b4.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72156514e00c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = uqm-megamod-addon-sol-textures
+ pkgdesc = Sol Textures for the Ur-Quan Masters MegaMod by Serosis.
+ pkgver = 0.8.0.85
+ pkgrel = 1
+ url = https://github.com/yokai-shogun/UQM-MegaMod-Content
+ arch = any
+ license = custom:CC BY-NC-SA 2.5
+ noextract = mm-0.8.0.85-sol-textures.uqm
+ source = https://github.com/yokai-shogun/UQM-MegaMod-Content/releases/download/0.8.0.85/mm-0.8.0.85-sol-textures.uqm
+ source = https://raw.githubusercontent.com/yokai-shogun/UQM-MegaMod-Content/master/LICENSE
+ md5sums = 5915c8d811345f1a27632c30190768f7
+ md5sums = 4f30efe3d129bd9a8bddd0d455c849f7
+
+pkgname = uqm-megamod-addon-sol-textures
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0580a22831c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : Victor Savcenco <victor dot sav at linux dot com>
+
+pkgname=uqm-megamod-addon-sol-textures
+_pkgname=uqm-megamod
+pkgver=0.8.0.85
+pkgrel=1
+pkgdesc="Sol Textures for the Ur-Quan Masters MegaMod by Serosis."
+arch=("any")
+url="https://github.com/yokai-shogun/UQM-MegaMod-Content"
+license=("custom:CC BY-NC-SA 2.5")
+
+source=(
+ "https://github.com/yokai-shogun/UQM-MegaMod-Content/releases/download/${pkgver}/mm-${pkgver}-sol-textures.uqm"
+ "https://raw.githubusercontent.com/yokai-shogun/UQM-MegaMod-Content/master/LICENSE"
+)
+
+md5sums=(
+ "5915c8d811345f1a27632c30190768f7"
+ "4f30efe3d129bd9a8bddd0d455c849f7"
+)
+
+noextract=("mm-${pkgver}-sol-textures.uqm")
+
+package() {
+ install -Dm644 "${srcdir}/mm-${pkgver}-sol-textures.uqm" "${pkgdir}/usr/share/uqm-megamod/content/addons/mm-${pkgver}-sol-textures.uqm"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}