summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-08-23 18:40:37 +0100
committerGrey Christoforo2015-08-23 18:40:37 +0100
commit2ddc63916d3118a86a2c93763c635d3280ddd0c4 (patch)
tree7cc14ef658f17d355730e0ce6f843cd914ddcd45
parent5eaeefa0795af37e72cffee60f5b3e385d3bf913 (diff)
downloadaur-2ddc63916d3118a86a2c93763c635d3280ddd0c4.tar.gz
include scripts in install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--scripts.patch10
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77c0c739e5c5..396bbab35653 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,8 +15,10 @@ pkgbase = uranium
depends = arcus
source = https://github.com/Ultimaker/uranium/archive/15.06.03.tar.gz
source = qt5.patch
+ source = scripts.patch
md5sums = 60c583b462494c2de015a678ba134eb3
md5sums = e4975dddd0524845b9574b4142274f5a
+ md5sums = d1832c5533c1ab6ceffd0a70768ccbd6
pkgname = uranium
diff --git a/PKGBUILD b/PKGBUILD
index 6675803121ab..5f64d6299821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,15 @@ arch=('i686' 'x86_64')
license=('GPLv3')
depends=('python' 'qt5-quickcontrols' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'arcus')
makedepends=('cmake')
-source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz" qt5.patch)
+source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz" qt5.patch scripts.patch)
md5sums=('60c583b462494c2de015a678ba134eb3'
- 'e4975dddd0524845b9574b4142274f5a')
+ 'e4975dddd0524845b9574b4142274f5a'
+ 'd1832c5533c1ab6ceffd0a70768ccbd6')
prepare(){
cd Uranium-${pkgver}
patch -Np1 -i ../qt5.patch
+ patch -Np1 -i ../scripts.patch
}
build() {
diff --git a/scripts.patch b/scripts.patch
new file mode 100644
index 000000000000..185293f552f9
--- /dev/null
+++ b/scripts.patch
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt 2015-07-27 08:51:09.000000000 +0100
++++ b/CMakeLists.txt 2015-08-23 18:30:00.642231499 +0100
+@@ -82,6 +82,7 @@
+ install(DIRECTORY UM DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages)
+ endif()
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
++install(DIRECTORY scripts DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium USE_SOURCE_PERMISSIONS)
+ install(DIRECTORY plugins DESTINATION lib/uranium)
+
+ include(CPackConfig.cmake)