summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-02-15 10:58:17 +0000
committerGrey Christoforo2016-02-15 10:58:17 +0000
commit8afbbb084e96d5f049eec35273e8748bb4de5cb3 (patch)
treea1fac36cee3c431542cb7d4647f0ca2146e4bbc2
parent2ddc63916d3118a86a2c93763c635d3280ddd0c4 (diff)
downloadaur-8afbbb084e96d5f049eec35273e8748bb4de5cb3.tar.gz
patch mswindows issue
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--Backend.py.patch17
-rw-r--r--PKGBUILD8
4 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 396bbab35653..4decc2642f9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Feb 15 10:58:12 UTC 2016
pkgbase = uranium
pkgdesc = A Python framework for building Desktop applications.
pkgver = 15.06.03
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Ultimaker/Uranium
arch = i686
arch = x86_64
@@ -16,9 +18,11 @@ pkgbase = uranium
source = https://github.com/Ultimaker/uranium/archive/15.06.03.tar.gz
source = qt5.patch
source = scripts.patch
+ source = Backend.py.patch
md5sums = 60c583b462494c2de015a678ba134eb3
md5sums = e4975dddd0524845b9574b4142274f5a
md5sums = d1832c5533c1ab6ceffd0a70768ccbd6
+ md5sums = 3d48bccc0d20475927c1badd81a95e35
pkgname = uranium
diff --git a/.gitignore b/.gitignore
index 4552cbc6889a..53fd2fc35bce 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
*.tar*
-pkg
-src
+pkg/
+src/
*.log
diff --git a/Backend.py.patch b/Backend.py.patch
new file mode 100644
index 000000000000..b9eb2318a3aa
--- /dev/null
+++ b/Backend.py.patch
@@ -0,0 +1,17 @@
+*** a/UM/Backend/Backend.py 2015-07-27 08:51:09.000000000 +0100
+--- b/UM/Backend/Backend.py 2016-02-15 10:53:34.986201167 +0000
+***************
+*** 89,100 ****
+ ## Start the (external) backend process.
+ def _runEngineProcess(self, command_list):
+ kwargs = {}
+- if subprocess.mswindows:
+- su = subprocess.STARTUPINFO()
+- su.dwFlags |= subprocess.STARTF_USESHOWWINDOW
+- su.wShowWindow = subprocess.SW_HIDE
+- kwargs["startupinfo"] = su
+- kwargs["creationflags"] = 0x00004000 #BELOW_NORMAL_PRIORITY_CLASS
+ return subprocess.Popen(command_list, stdin=subprocess.DEVNULL, stdout=subprocess.PIPE, stderr=subprocess.PIPE, **kwargs)
+
+ def _storeOutputToLogThread(self, handle):
+--- 89,94 ----
diff --git a/PKGBUILD b/PKGBUILD
index 5f64d6299821..3091db341082 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
pkgname=uranium
pkgver=15.06.03
-pkgrel=1
+pkgrel=2
pkgdesc="A Python framework for building Desktop applications."
url="https://github.com/Ultimaker/Uranium"
arch=('i686' 'x86_64')
license=('GPLv3')
depends=('python' 'qt5-quickcontrols' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'arcus')
makedepends=('cmake')
-source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz" qt5.patch scripts.patch)
+source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz" qt5.patch scripts.patch Backend.py.patch)
md5sums=('60c583b462494c2de015a678ba134eb3'
'e4975dddd0524845b9574b4142274f5a'
- 'd1832c5533c1ab6ceffd0a70768ccbd6')
+ 'd1832c5533c1ab6ceffd0a70768ccbd6'
+ '3d48bccc0d20475927c1badd81a95e35')
prepare(){
cd Uranium-${pkgver}
patch -Np1 -i ../qt5.patch
patch -Np1 -i ../scripts.patch
+ patch -Np1 -i ../Backend.py.patch
}
build() {