summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-08-03 00:27:40 +0200
committerGrey Christoforo2015-08-03 00:27:40 +0200
commit9b9d8172218953a0b8b3c6c70f415cc25ff7559e (patch)
tree7edd5cd227b2e63d28285544b688c8d2650beeb6
downloadaur-9b9d8172218953a0b8b3c6c70f415cc25ff7559e.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..135f7ac1607b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = uranium
+ pkgdesc = A Python framework for building Desktop applications.
+ pkgver = 15.06.02
+ pkgrel = 1
+ url = https://github.com/Ultimaker/Uranium
+ arch = any
+ license = GPLv3
+ makedepends = cmake
+ depends = python
+ depends = qt5-quickcontrols
+ depends = pyqt5-common
+ depends = python-pyqt5
+ depends = python-numpy
+ depends = arcus
+ source = https://github.com/Ultimaker/uranium/archive/15.06.02.tar.gz
+ md5sums = c3b5e070090b2d026e1547ef8d4532fe
+
+pkgname = uranium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa47f7aee4bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Grey Christoforo <grey[at]christoforo[dot]net>
+pkgname=uranium
+pkgver=15.06.02
+pkgrel=1
+pkgdesc="A Python framework for building Desktop applications."
+url="https://github.com/Ultimaker/Uranium"
+arch=('any')
+license=('GPLv3')
+depends=('python' 'qt5-quickcontrols' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'arcus')
+#optdepends=('java-runtime')
+makedepends=('cmake')
+conflicts=()
+replaces=()
+backup=()
+#install='foo.install'
+source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('c3b5e070090b2d026e1547ef8d4532fe')
+
+build() {
+ cd "${srcdir}/Uranium-${pkgver}"
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/Uranium-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ #install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: