summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-10-16 17:14:12 -0400
committerAdam Goldsmith2015-10-16 17:14:12 -0400
commit63c237dfd23ebff36d55c9790d4212c7361a1c29 (patch)
tree420576cb11332b4d0427ce9f85234ae3a657ecca
parent2ddc63916d3118a86a2c93763c635d3280ddd0c4 (diff)
downloadaur-63c237dfd23ebff36d55c9790d4212c7361a1c29.tar.gz
Convert to git version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
-rw-r--r--site-packages-dir.patch15
3 files changed, 50 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 396bbab35653..cb3615b7be4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
-pkgbase = uranium
+pkgbase = uranium-git
pkgdesc = A Python framework for building Desktop applications.
- pkgver = 15.06.03
+ pkgver = 15.06.03.655.g2e43338
pkgrel = 1
url = https://github.com/Ultimaker/Uranium
arch = i686
arch = x86_64
- license = GPLv3
+ license = GPL3
makedepends = cmake
+ makedepends = git
depends = python
depends = qt5-quickcontrols
depends = pyqt5-common
depends = python-pyqt5
depends = python-numpy
- depends = arcus
- source = https://github.com/Ultimaker/uranium/archive/15.06.03.tar.gz
- source = qt5.patch
- source = scripts.patch
- md5sums = 60c583b462494c2de015a678ba134eb3
- md5sums = e4975dddd0524845b9574b4142274f5a
- md5sums = d1832c5533c1ab6ceffd0a70768ccbd6
+ depends = libarcus-git
+ provides = uranium
+ conflicts = uranium
+ source = git+https://github.com/Ultimaker/Uranium.git
+ source = site-packages-dir.patch
+ md5sums = SKIP
+ md5sums = 104a4190a8df6b305801fefd0fb55387
-pkgname = uranium
+pkgname = uranium-git
diff --git a/PKGBUILD b/PKGBUILD
index 5f64d6299821..b766ed9b18b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+# Original Author: Grey Christoforo <first name [at] last name [dot] net>
-pkgname=uranium
-pkgver=15.06.03
+pkgname=uranium-git
+pkgver=15.06.03.655.g2e43338
pkgrel=1
pkgdesc="A Python framework for building Desktop applications."
url="https://github.com/Ultimaker/Uranium"
arch=('i686' 'x86_64')
-license=('GPLv3')
-depends=('python' 'qt5-quickcontrols' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'arcus')
-makedepends=('cmake')
-source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz" qt5.patch scripts.patch)
-md5sums=('60c583b462494c2de015a678ba134eb3'
- 'e4975dddd0524845b9574b4142274f5a'
- 'd1832c5533c1ab6ceffd0a70768ccbd6')
+license=('GPL3')
+provides=('uranium')
+conflicts=('uranium')
+depends=('python' 'qt5-quickcontrols' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'libarcus-git')
+makedepends=('cmake' 'git')
+source=('git+https://github.com/Ultimaker/Uranium.git' 'site-packages-dir.patch')
+md5sums=('SKIP' '104a4190a8df6b305801fefd0fb55387')
+
+pkgver() {
+ cd Uranium
+ git describe --tags | sed 's/-/./g'
+}
prepare(){
- cd Uranium-${pkgver}
- patch -Np1 -i ../qt5.patch
- patch -Np1 -i ../scripts.patch
+ cd Uranium
+ patch -Np1 -i ../site-packages-dir.patch
}
build() {
- cd Uranium-${pkgver}
- cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+ mkdir -p Uranium/build
+ cd Uranium/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd Uranium-${pkgver}
+ cd Uranium/build
make DESTDIR="${pkgdir}" install
- SITE_PACKAGES=$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
- mkdir -p "${pkgdir}${SITE_PACKAGES}"
- mv "${pkgdir}"/usr/lib/python3/dist-packages/* "${pkgdir}${SITE_PACKAGES}"/.
- rm -rf "${pkgdir}"/usr/lib/python3
+
#install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/site-packages-dir.patch b/site-packages-dir.patch
new file mode 100644
index 000000000000..68b906725884
--- /dev/null
+++ b/site-packages-dir.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -73,11 +73,7 @@ if(GETTEXT_FOUND)
+ endforeach()
+ endif()
+
+-if(APPLE OR WIN32)
+- install(DIRECTORY UM DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
+-else()
+- install(DIRECTORY UM DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages)
+-endif()
++install(DIRECTORY UM DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
+ install(DIRECTORY plugins DESTINATION lib/uranium)
+