summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-02-07 18:56:18 -0500
committerChris Severance2018-02-07 18:56:18 -0500
commit3af591aff26bf949eda4cddedf7aa5fb17f6ab5b (patch)
tree9b7c6699aa72cede979d751415f09d66830743f1
parente4e1c5155a91be473a596a53f6a25fd8bf058ba9 (diff)
downloadaur-3af591aff26bf949eda4cddedf7aa5fb17f6ab5b.tar.gz
Fix issue regarding the recent update of crypto++
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f081b0c83eae..03c79fbfeffa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jun 22 06:21:19 UTC 2017
+# Wed Feb 7 23:55:44 UTC 2018
pkgbase = urbackup-server-git
- pkgdesc = Client/Server network backup for Windows and Linux, builds server or client
+ pkgdesc = Client/Server network backup for Windows Workgroups and Linux, builds server or client
pkgver = 2.1.20.r15.g4d2bebba
- pkgrel = 1
+ pkgrel = 2
url = https://www.urbackup.org/
install = urbackup-server.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 5719d6508f85..62c4f65ee74c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,8 +46,8 @@ else
fi
pkgname="${_pkgname}-git"
pkgver=2.1.20.r15.g4d2bebba
-pkgrel=1
-pkgdesc='Client/Server network backup for Windows and Linux, builds server or client'
+pkgrel=2
+pkgdesc='Client/Server network backup for Windows Workgroups and Linux, builds server or client'
arch=('i686' 'x86_64')
url='https://www.urbackup.org/'
license=('GPL')
@@ -230,6 +230,15 @@ prepare() {
false
fi
+ cat >> 'cryptoplugin/cryptopp_inc.h' <<EOL
+
+#if (CRYPTOPP_VERSION >= 600) && (__cplusplus >= 201103L)
+ using byte = CryptoPP::byte;
+#else
+ typedef unsigned char byte;
+#endif
+EOL
+
if [ "${_opt_BuildClient}" -ne 0 ]; then
ln -sf '../urbackup_frontend_wx' 'client'