summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-10-24 19:15:08 -0400
committerChris Severance2016-10-24 19:15:08 -0400
commit4803573cc71127c0c04a8a6db24d1985a11f4c6a (patch)
tree538a546aa0be179fc726bf973cda4f6645bee37c
parent33da1ce86c246da7e64271c118f042912da073ea (diff)
downloadaur-4803573cc71127c0c04a8a6db24d1985a11f4c6a.tar.gz
Fix assert for gcc6.2
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47df2614ce05..9dca0808d8a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -151,6 +151,8 @@ if ! :; then
-e 's:array\[:html_array\[:g' 'stringtools.cpp'
sed -i -e 's:^#define _exit exit:// &:g' 'cryptoplugin/dllmain.cpp'
fi
+ # Simple assert errors, probably fixed soon
+ sed -i -e 's:^#include "AESGCMDecryption.h".*$:#include <assert.h>\r\n&:g' 'cryptoplugin/AESGCMDecryption.cpp'
# fix the build scripts
#sed -i -e 's:response.readall():response.read():g' 'build/replace_versions.py' # python was always a bad choice for these text replacements. As of Python 3.5 this script doesn't work at all and read() is not a proper replacement for readall().