summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2016-02-02 11:46:55 +0100
committerzoe2016-02-02 11:46:55 +0100
commit2594fca9bcbeb5f434b3ed768599c714ea45aeab (patch)
tree4a1a525141734f9d7482443d9021cdd7e30d7e2e
downloadaur-2594fca9bcbeb5f434b3ed768599c714ea45aeab.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--urbanlightscape.desktop9
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..620264a59d0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 10:46:01 UTC 2016
+pkgbase = urbanlightscape
+ pkgdesc = A photo filter for exposure, brightness and lighting correction
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://www.indii.org/software/urbanlightscape
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = wxgtk
+ depends = desktop-file-utils
+ source = http://www.indii.org/files/urbanlightscape/releases/urbanlightscape-1.4.0.tar.gz
+ source = http://www.indii.org/images/urbanlightscape_128.png
+ source = urbanlightscape.desktop
+ md5sums = e5097a9a48f2f2cde1d641380f050dc6
+ md5sums = b6940433e6e0bcd85fea1e311c520804
+ md5sums = 295a61ac999850102e1330548b5a4d61
+
+pkgname = urbanlightscape
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71a3f02f3745
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer : zoe <chp321 at gmail dot com>
+# Contributor: Josef Lusticky <evramp@gmail.com>
+
+pkgname=urbanlightscape
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A photo filter for exposure, brightness and lighting correction"
+arch=(i686 x86_64)
+url="http://www.indii.org/software/urbanlightscape"
+license=('GPL')
+depends=('wxgtk' 'desktop-file-utils')
+makedepends=('boost')
+source=("http://www.indii.org/files/${pkgname}/releases/${pkgname}-${pkgver}.tar.gz"
+ "http://www.indii.org/images/${pkgname}_128.png" "${pkgname}.desktop")
+md5sums=('e5097a9a48f2f2cde1d641380f050dc6'
+ 'b6940433e6e0bcd85fea1e311c520804'
+ '295a61ac999850102e1330548b5a4d61')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+
+ # desktop file
+ install -Dm644 ../${pkgname}.desktop \
+ "$pkgdir/usr/share/applications/${pkgname}.desktop"
+
+ # icon
+ install -Dm644 ../${pkgname}_128.png \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
+
diff --git a/urbanlightscape.desktop b/urbanlightscape.desktop
new file mode 100644
index 000000000000..162f4343aadb
--- /dev/null
+++ b/urbanlightscape.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=UrbanLightscape
+GenericName=UrbanLightscape
+Comment=A photo filter for exposure, brightness and lighting correction
+Type=Application
+Exec=urbanlightscape %f
+Icon=urbanlightscape
+Terminal=false
+Categories=Graphics;2DGraphics;