summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Atkinson2015-06-23 18:15:25 -0400
committerChris Atkinson2015-06-23 18:15:25 -0400
commite62eeeca22779b3390cf7ed9d6ad1394b881710f (patch)
tree1030615380f53615a37503899a69a8cb497e37c3
downloadaur-e62eeeca22779b3390cf7ed9d6ad1394b881710f.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9b0b9d67b79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = urfkill-git
+ pkgdesc = Handle rfkill events in userspace
+ pkgver = urfkill.0.5.0.43.g3c7f43e
+ pkgrel = 1
+ url = https://github.com/lcp/urfkill
+ arch = x86_64
+ license = GPL2
+ makedepends = glibc>=2.20
+ makedepends = git
+ makedepends = gtk-doc
+ depends = expat>=2.01
+ depends = gobject-introspection>=0.6.7
+ depends = libsystemd>=148
+ depends = polkit>=0.91
+ depends = systemd
+ provides = urfkill
+ conflicts = urfkill
+ source = urfkill::git+https://github.com/lcp/urfkill.git
+ md5sums = SKIP
+
+pkgname = urfkill-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..165991ce36c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: snakeroot <cwa AT pipeline DOT com>
+
+_pkgname=urfkill
+pkgname=urfkill-git
+pkgver=urfkill.0.5.0.43.g3c7f43e
+pkgrel=1
+pkgdesc="Handle rfkill events in userspace"
+arch=('x86_64')
+url="https://github.com/lcp/urfkill"
+license=('GPL2')
+depends=('expat>=2.01' 'gobject-introspection>=0.6.7' 'libsystemd>=148' 'polkit>=0.91' 'systemd')
+makedepends=('glibc>=2.20' 'git' 'gtk-doc')
+conflicts=('urfkill')
+provides=('urfkill')
+source=("$_pkgname::git+https://github.com/lcp/urfkill.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed -e 's|-|.|g'
+}
+
+build() {
+ cd $_pkgname
+ ./autogen.sh
+ ./configure --bindir=/usr/bin --datarootdir=/usr/share --libdir=/usr/lib libexecdir=/usr/lib --localstatedir=/var --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --with-session-tracking=systemd
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+}