summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof Dermont2015-09-07 17:24:32 +0200
committerKrzysztof Dermont2015-09-07 17:24:32 +0200
commit4107dfb4f88f7238b2073918270fec5f79ca7108 (patch)
tree37a1386a613af8d519e803ee73df2dce52b46dc6
parente7c6506565061bc0466d52ed1b6d805e0392f591 (diff)
downloadaur-4107dfb4f88f7238b2073918270fec5f79ca7108.tar.gz
Add conflicts, replaces and provides
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21bf4be1bbfc..8fe3ea071597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = urho3d
pkgdesc = Urho3D is a free lightweight, cross-platform 2D and 3D game engine implemented in C++ and released under the MIT license.
pkgver = 1.4
- pkgrel = 1
+ pkgrel = 2
url = http://urho3d.github.io
install = urho3d.install
arch = i686
@@ -11,6 +11,9 @@ pkgbase = urho3d
depends = libx11
depends = libgl
depends = libxrandr
+ provides = urho3d
+ conflicts = urho3d-git
+ replaces = urho3d-git
source = https://github.com/urho3d/Urho3D/archive/1.4.tar.gz
md5sums = 0eaf743ce192f63ba3580c9b5d30ef3b
sha1sums = dfcf0c8623b9fc89998bf9f3b8f18244f079cfb9
diff --git a/PKGBUILD b/PKGBUILD
index aeb37c9a5121..2f255f490398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
pkgname=urho3d
pkgver=1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Urho3D is a free lightweight, cross-platform 2D and 3D game engine implemented in C++ and released under the MIT license."
arch=('i686' 'x86_64')
url="http://urho3d.github.io"
license=('MIT')
depends=("libx11" "libgl" "libxrandr")
makedepends=('cmake')
+conflicts=("$pkgname-git")
+replaces=("$pkgname-git")
+provides=("$pkgname")
source=("https://github.com/urho3d/Urho3D/archive/1.4.tar.gz")
md5sums=('0eaf743ce192f63ba3580c9b5d30ef3b')
sha1sums=('dfcf0c8623b9fc89998bf9f3b8f18244f079cfb9')
@@ -22,4 +25,6 @@ build() {
package() {
cd "$srcdir/Urho3D-$pkgver/build"
make DESTDIR="$pkgdir/" install
+ cd "$pkgdir/usr/bin"
+ mv "./Editor.sh" "./urho3d-editor.sh"
}