summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyon Sherman2015-06-08 22:53:57 -0500
committerRyon Sherman2015-06-08 22:53:57 -0500
commit3d3a80ee9c6c03b2ad5874f35ee9d7c1619251ce (patch)
treeba7c88a49284b91018a45145403b6305864b7576
downloadaur-3d3a80ee9c6c03b2ad5874f35ee9d7c1619251ce.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a5fc1a02c5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = urlcrazy
+ pkgdesc = Generate and test domain typos and variations to detect and perform typo squatting, URL hijacking, phishing, and corporate espionage.
+ pkgver = 0.5
+ pkgrel = 3
+ url = http://www.morningstarsecurity.com/research/urlcrazy
+ arch = any
+ license = custom
+ depends = ruby
+ source = http://www.morningstarsecurity.com/downloads/urlcrazy-0.5.tar.gz
+ md5sums = bfe2e0c71cc5160530b773f15d242964
+
+pkgname = urlcrazy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc5c6785109
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: /dev/rs0 <rs0@secretco.de.com>
+
+pkgname=urlcrazy
+pkgver=0.5
+pkgrel=3
+pkgdesc="Generate and test domain typos and variations to detect and perform typo squatting, URL hijacking, phishing, and corporate espionage."
+
+arch=('any')
+license=('custom')
+url="http://www.morningstarsecurity.com/research/urlcrazy"
+
+depends=('ruby')
+source=("http://www.morningstarsecurity.com/downloads/urlcrazy-${pkgver}.tar.gz")
+md5sums=('bfe2e0c71cc5160530b773f15d242964')
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/urlcrazy/urlcrazy" "${pkgdir}/usr/bin/urlcrazy"
+
+ install -d "${pkgdir}/usr/share/urlcrazy"
+ cp -a "${srcdir}/urlcrazy-${pkgver}/." "${pkgdir}/usr/share/urlcrazy"
+
+ install -d "${pkgdir}/usr/share/doc/urlcrazy"
+ ln -s "/usr/share/urlcrazy/README" "${pkgdir}/usr/share/doc/urlcrazy"
+}