summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Down2016-10-06 12:43:56 +0100
committerChris Down2016-10-06 12:43:56 +0100
commit9d1557c1c1aa138b899e508cd4f84556efce8e2e (patch)
tree41fe0aa05698adae14580d3d5247625bedacb2d1
downloadaur-9d1557c1c1aa138b899e508cd4f84556efce8e2e.tar.gz
Release 0.8.3-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
-rw-r--r--urlscan.install11
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc0ec3e53794
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Oct 6 11:42:27 UTC 2016
+pkgbase = urlscan
+ pkgdesc = Replacement for urlview with html context and other improvements.
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://github.com/firecat53/urlscan
+ install = urlscan.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-urwid
+ source = https://github.com/firecat53/urlscan/archive/0.8.3.tar.gz
+ md5sums = b94925e969f0e8e3cba9d658562e138e
+
+pkgname = urlscan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e20527dfcd53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Chris Down <chris@chrisdown.name>
+# Contributor: Scott Hansen (firecat53) firecat4153 at gmail
+
+pkgname=urlscan
+pkgver=0.8.3
+pkgrel=1
+pkgdesc="Replacement for urlview with html context and other improvements."
+url=https://github.com/firecat53/urlscan
+arch=(any)
+license=(GPL)
+depends=(python python-urwid)
+makedepends=(git python-setuptools)
+source=("https://github.com/firecat53/urlscan/archive/$pkgver.tar.gz")
+md5sums=('b94925e969f0e8e3cba9d658562e138e')
+install=urlscan.install
+
+package() {
+ cd "${srcdir?}/$pkgname-$pkgver" || return
+ ./setup.py install --root="${pkgdir?}"
+}
+
diff --git a/urlscan.install b/urlscan.install
new file mode 100644
index 000000000000..d6319b942944
--- /dev/null
+++ b/urlscan.install
@@ -0,0 +1,11 @@
+## arg 1: the new package version
+post_install() {
+cat <<End-of-message
+
+ Configuration:
+ The default system browser will be used (if set) to open URLs. If a particular browser is desired, set the BROWSER environment variable. For example, add:
+ export BROWSER="chromium"
+ to .bashrc
+End-of-message
+}
+# vim:set ts=2 sw=2 et: