summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordavidovitch2016-04-19 19:27:56 +0200
committerdavidovitch2016-04-19 19:27:56 +0200
commit6910f688b9efbaa5c6f06c717a0059ab07547765 (patch)
tree5202c3b5afe0053f6e1b5301f8156625abb23321
downloadaur-urw-arial.tar.gz
creating new package, version 20060321-1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--LICENSE18
-rw-r--r--PKGBUILD46
-rw-r--r--urw-arial.install52
-rw-r--r--urw-arial.maps1
6 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e28a308a91f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = urw-arial
+ pkgdesc = URW Arial Type1 fonts from CTAN (for texlive)
+ pkgver = 20060321
+ pkgrel = 1
+ url = http://www.ctan.org/pkg/urw-arial
+ install = urw-arial.install
+ arch = any
+ license = CUSTOM:alladin
+ depends = texlive-core
+ source = http://mirrors.ctan.org/fonts/urw/arial.zip
+ source = urw-arial.maps
+ source = LICENSE
+ md5sums = 4ad05e902e727fecc4f55f8d737e10a5
+ md5sums = 14a40d8b0873eabaa33bfd1d6c5304f2
+ md5sums = 5687e45ec13eb0290e38e48ce3903e47
+
+pkgname = urw-arial
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a14aed938239
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/*
+pkg/*
+*.zip
+*.xz
+*.gz
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f2d436a3009d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,18 @@
+Distribution and modification of the the URW Arial fonts
+are subject to the Aladdin Free Public License
+<http://www.artifex.com/downloads/doc/Public.htm>
+
+ Copyright (c) 2000 by (URW)++ Design & Development
+
+The TeX font metrics, virtual fonts and font definition
+files for URW Arial i.e., the files in the archive
+ua1.zip, may be distributed and/or modified under the
+conditions of the LaTeX Project Public License, either
+version 1.3 of this license or (at your option) any later
+version. The latest version of this license is in
+http://www.latex-project.org/lppl.txt and version 1.3 or
+later is part of all distributions of LaTeX version
+2003/12/01 or later.
+
+ Copyright (c) 2006 Walter Schmidt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d37642fa924
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: David Verelst <david.verelst@gmail.com>
+# based on urw-garamond in AUR
+pkgname=urw-arial
+pkgver=20060321
+pkgrel=1
+depends=('texlive-core')
+pkgdesc="URW Arial Type1 fonts from CTAN (for texlive)"
+arch=('any')
+license=('CUSTOM:alladin')
+url="http://www.ctan.org/pkg/urw-arial"
+depends=(texlive-core)
+install=$pkgname.install
+source=(http://mirrors.ctan.org/fonts/urw/arial.zip urw-arial.maps LICENSE)
+md5sums=('4ad05e902e727fecc4f55f8d737e10a5'
+ '14a40d8b0873eabaa33bfd1d6c5304f2'
+ '5687e45ec13eb0290e38e48ce3903e47')
+
+package() {
+ cd "$srcdir"
+ _texmf_root=usr/share/texmf-dist
+ install -d -m755 "$pkgdir/var/lib/texmf/arch/installedpkgs"
+ install -m 644 $pkgname.maps "$pkgdir/var/lib/texmf/arch/installedpkgs"
+
+ install -d "$pkgdir/$_texmf_root/tex/latex/uarial"
+ install -m 644 arial/latex/* $pkgdir/usr/share/texmf-dist/tex/latex/uarial
+
+ install -d "$pkgdir/$_texmf_root/fonts/afm/urw/arial"
+ install -d "$pkgdir/$_texmf_root/fonts/tfm/urw/arial"
+ install -d "$pkgdir/$_texmf_root/fonts/type1/urw/arial"
+ install -d "$pkgdir/$_texmf_root/fonts/vf/urw/arial"
+ install -m 644 arial/afm/*.afm "$pkgdir/$_texmf_root/fonts/afm/urw/arial/"
+ install -m 644 arial/tfm/*.tfm "$pkgdir/$_texmf_root/fonts/tfm/urw/arial/"
+ install -m 644 arial/type1/*.pfb "$pkgdir/$_texmf_root/fonts/type1/urw/arial/"
+ install -m 644 arial/vf/*.vf "$pkgdir/$_texmf_root/fonts/vf/urw/arial/"
+
+ install -d "$pkgdir/$_texmf_root/fonts/map/dvips/uarial"
+ install -m 644 arial/map/ua1.map "$pkgdir/$_texmf_root/fonts/map/dvips/uarial/"
+ install -d "$pkgdir/$_texmf_root/fonts/map/pdftex/uarial"
+ install -m 644 arial/map/ua1.map "$pkgdir/$_texmf_root/fonts/map/pdftex/uarial/"
+
+ install -d "$pkgdir/$_texmf_root/fonts/map/vtex/uarial"
+ install -m 644 arial/map/ua1.ali "$pkgdir/$_texmf_root/fonts/map/vtex/uarial/"
+
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/urw-arial.install b/urw-arial.install
new file mode 100644
index 000000000000..ad9a8be6f3d6
--- /dev/null
+++ b/urw-arial.install
@@ -0,0 +1,52 @@
+PKGNAME="urw-arial"
+UPDMAP="etc/texmf/web2c/updmap.cfg"
+UPDMAPLOCAL="etc/texmf/web2c/updmap-local.cfg"
+SYNCWITHTREES=''
+
+MAPFILE="var/lib/texmf/arch/installedpkgs/$PKGNAME.maps"
+
+post_install() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}
+
+post_upgrade() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash $SYNCWITHTREES
+ echo " done."
+}
+
+pre_remove() {
+for m in `cut -d' ' -f2 $MAPFILE`; do
+ sed -i "/\s$m/d" $UPDMAP ;
+done
+}
+
+post_remove() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}
diff --git a/urw-arial.maps b/urw-arial.maps
new file mode 100644
index 000000000000..b9d5c496a40c
--- /dev/null
+++ b/urw-arial.maps
@@ -0,0 +1 @@
+Map ua1.map