summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVale Cofer-Shabica2017-11-14 17:05:46 -0500
committerVale Cofer-Shabica2017-11-14 17:05:46 -0500
commit8bfd5079a1660def0aee0e11ab4689e58d90b852 (patch)
tree565915ef83e92b675170d62532471a0512cebf23
parentbdd9cc963988707a7202fc6f6163797a24524961 (diff)
downloadaur-8bfd5079a1660def0aee0e11ab4689e58d90b852.tar.gz
Hooked into Arch's system for fontmaps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD34
-rw-r--r--urw-classico.install24
-rw-r--r--urw-classico.maps1
4 files changed, 23 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3990f29451b6..6aaad8e0b905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = urw-classico
pkgdesc = URW Classico font from CTAN (for texlive)
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.ctan.org/tex-archive/fonts/urw/classico
- install = urw-classico.install
arch = any
license = CUSTOM:alladin
depends = texlive-core
noextract = classico.tds.zip
source = http://mirrors.ctan.org/install/fonts/urw/classico.tds.zip
+ source = urw-classico.maps
source = license
md5sums = 166eb8e7f2e1ca764b02e00aae5e86fb
+ md5sums = 9a675e3b5016e8b1a15a228c6caf1fda
md5sums = 7689a58e80bcc8546b76e397b83a572b
pkgname = urw-classico
diff --git a/PKGBUILD b/PKGBUILD
index f210f1cf7c72..7bed2e91e6bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,27 @@
pkgname=urw-classico
pkgver=1.0
-pkgrel=3
-pkgdesc='URW Classico font from CTAN (for texlive)'
-arch=('any')
-license=('CUSTOM:alladin')
-url='https://www.ctan.org/tex-archive/fonts/urw/classico'
-depends=('texlive-core')
-install=$pkgname.install
-source=('http://mirrors.ctan.org/install/fonts/urw/classico.tds.zip'
- 'license')
-noextract=('classico.tds.zip')
+pkgrel=4
+pkgdesc="URW Classico font from CTAN (for texlive)"
+arch=("any")
+license=("CUSTOM:alladin")
+url="https://www.ctan.org/tex-archive/fonts/urw/classico"
+depends=("texlive-core")
+source=("http://mirrors.ctan.org/install/fonts/urw/classico.tds.zip"
+ "$pkgname.maps"
+ "license")
+noextract=("classico.tds.zip")
md5sums=('166eb8e7f2e1ca764b02e00aae5e86fb'
+ '9a675e3b5016e8b1a15a228c6caf1fda'
'7689a58e80bcc8546b76e397b83a572b')
package() {
- cd "$srcdir"
- texmf_root=usr/share/texmf
- mkdir -p "$pkgdir/$texmf_root"
- bsdtar -poxf $srcdir/classico.tds.zip -C "$pkgdir/$texmf_root"
- install -Dm644 $srcdir/license "$pkgdir/usr/share/licenses/$pkgname/license"
+ install -m755 -d $pkgdir/usr/share/texmf
+ bsdtar -poxf $srcdir/classico.tds.zip -C $pkgdir/usr/share/texmf
+
+ install -m755 -d $pkgdir/var/lib/texmf/arch/installedpkgs
+ install -m644 $pkgname.maps $pkgdir/var/lib/texmf/arch/installedpkgs
+
+ install -m755 -d $pkgdir/usr/share/licenses
+ install -Dm644 $srcdir/license $pkgdir/usr/share/licenses/$pkgname
}
diff --git a/urw-classico.install b/urw-classico.install
deleted file mode 100644
index 0b49e142cbb2..000000000000
--- a/urw-classico.install
+++ /dev/null
@@ -1,24 +0,0 @@
-TEXMFLOCAL="/usr/share/texmf"
-UPDMAP="fonts/map/dvips/classico/"
-MAP="classico.map"
-
-post_install() {
- echo ">>> texlive: updating the filename database..."
- mktexlsr
- echo ">>> texlive: updating the fontmap files with updmap..."
- cd $TEXMFLOCAL/$UPDMAP
- updmap-sys --quiet --enable Map=$MAP
- echo " done."
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- echo ">>> texlive: updating the filename database..."
- mktexlsr
- echo ">>> texlive: updating the fontmap files with updmap..."
- updmap-sys --quiet
- echo " done."
-}
diff --git a/urw-classico.maps b/urw-classico.maps
new file mode 100644
index 000000000000..f2a52ac73d4b
--- /dev/null
+++ b/urw-classico.maps
@@ -0,0 +1 @@
+Map classico.map \ No newline at end of file