summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 19:04:48 +0200
committerAndrzej Giniewicz2015-07-07 19:04:48 +0200
commitfff580e9804181578c46eba828c9bff48ed25bfd (patch)
tree22924ffe647965e634de9aa2a447e17e4f72d5bb
downloadaur-fff580e9804181578c46eba828c9bff48ed25bfd.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD30
-rw-r--r--urw-garamond.install52
-rw-r--r--urw-garamond.maps1
5 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37feb00ac13e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = urw-garamond
+ pkgdesc = URW Garamond No8 Adobe Type1 fonts from CTAN (for texlive)
+ pkgver = 1.0
+ pkgrel = 9
+ url = http://tug.ctan.org/pkg/urw-garamond
+ install = urw-garamond.install
+ arch = any
+ license = CUSTOM:alladin
+ depends = texlive-core
+ source = http://mirror.ctan.org/fonts/urw/garamond.zip
+ source = urw-garamond.maps
+ source = LICENSE
+ md5sums = a60beaf12c12c69eeb8fdc82bd481949
+ md5sums = c8d3a18033c3ab511391862ae8dfd6f8
+ md5sums = 26381247b9d120f68e6c3dae624d6484
+
+pkgname = urw-garamond
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a3f6d37c36aa
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+Distribution and modification of the the URW Garamond fonts
+are subject to the Aladdin Free Public License
+<http://www.artifex.com/downloads/doc/Public.htm>
+
+ Copyright (c) 2000 by (URW)++ Design & Development
+
+The font GaramondNo8 Italic has been modified, as compared
+with the version from the original distribution site
+<http://www.artifex.com/downloads/>; credits to Ralf Stubner
+for fixing the broken quotedblleft character.
+
+
+The TeX font metrics, virtual fonts and font definition
+files for URW Garamond, i.e., the files in the archive
+ugm.zip, may be distributed and/or modified under the
+conditions of the LaTeX Project Public License, either
+version 1.3 of this license or (at your option) any later
+version. The latest version of this license is in
+http://www.latex-project.org/lppl.txt and version 1.3 or
+later is part of all distributions of LaTeX version
+2003/12/01 or later.
+
+ Copyright (c) 2005 Walter Schmidt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2020caaa235
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: bender02 at archlinux dot us
+pkgname=urw-garamond
+pkgver=1.0
+pkgrel=9
+pkgdesc="URW Garamond No8 Adobe Type1 fonts from CTAN (for texlive)"
+arch=('any')
+license=('CUSTOM:alladin')
+url=("http://tug.ctan.org/pkg/urw-garamond")
+depends=(texlive-core)
+install=$pkgname.install
+source=(http://mirror.ctan.org/fonts/urw/garamond.zip urw-garamond.maps LICENSE)
+md5sums=('a60beaf12c12c69eeb8fdc82bd481949'
+ 'c8d3a18033c3ab511391862ae8dfd6f8'
+ '26381247b9d120f68e6c3dae624d6484')
+
+package() {
+ cd "$srcdir"
+ _texmf_root=usr/share/texmf-dist
+ install -d -m755 "$pkgdir/var/lib/texmf/arch/installedpkgs"
+ install -m 644 $pkgname.maps "$pkgdir/var/lib/texmf/arch/installedpkgs"
+ install -d "$pkgdir/$_texmf_root/fonts/afm/urw/garamond"
+ install -d "$pkgdir/$_texmf_root/fonts/type1/urw/garamond"
+ install -m 644 garamond/*.afm "$pkgdir/$_texmf_root/fonts/afm/urw/garamond"
+ install -m 644 garamond/*.pfb "$pkgdir/$_texmf_root/fonts/type1/urw/garamond"
+ bsdtar -x --no-same-permissions -f garamond/ugm.zip -C "$pkgdir/$_texmf_root"
+ rm -rf "$pkgdir/$_texmf_root/"{doc,dvips}
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/urw-garamond.install b/urw-garamond.install
new file mode 100644
index 000000000000..3a4e066fe3ec
--- /dev/null
+++ b/urw-garamond.install
@@ -0,0 +1,52 @@
+PKGNAME="urw-garamond"
+UPDMAP="etc/texmf/web2c/updmap.cfg"
+UPDMAPLOCAL="etc/texmf/web2c/updmap-local.cfg"
+SYNCWITHTREES=''
+
+MAPFILE="var/lib/texmf/arch/installedpkgs/$PKGNAME.maps"
+
+post_install() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}
+
+post_upgrade() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash $SYNCWITHTREES
+ echo " done."
+}
+
+pre_remove() {
+for m in `cut -d' ' -f2 $MAPFILE`; do
+ sed -i "/\s$m/d" $UPDMAP ;
+done
+}
+
+post_remove() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}
diff --git a/urw-garamond.maps b/urw-garamond.maps
new file mode 100644
index 000000000000..bf5189085072
--- /dev/null
+++ b/urw-garamond.maps
@@ -0,0 +1 @@
+Map ugm.map