summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Archive Bot2015-08-17 23:18:09 +0200
committerStanislav Seletskiy2015-09-21 11:51:25 +0600
commit774ecaea9637ca942070e2780e872ab78451577d (patch)
tree483528246dcb99194ce86c287520e2d682332e78
downloadaur-774ecaea9637ca942070e2780e872ab78451577d.tar.gz
Initial AUR Archive commit of 'urxvt-autocomplete-all-the-things-git'
(full history will be added later)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
-rw-r--r--autocomplete-ALL-the-things.install12
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a203cd9afd51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = urxvt-autocomplete-all-the-things-git
+ pkgdesc = an urxvt plugin allowing user to easily complete words
+ pkgver = 20120115
+ pkgrel = 1
+ url = https://github.com/Vifon/autocomplete-ALL-the-things
+ install = autocomplete-ALL-the-things.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = rxvt-unicode
+
+pkgname = urxvt-autocomplete-all-the-things-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91549e3f6292
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Wojciech Siewierski <darkvifon at gmail dot com>
+pkgname=urxvt-autocomplete-all-the-things-git
+pkgver=20120115
+pkgrel=1
+pkgdesc="an urxvt plugin allowing user to easily complete words"
+url="https://github.com/Vifon/autocomplete-ALL-the-things"
+arch=('any')
+license=('GPL')
+depends=('rxvt-unicode')
+makedepends=('git')
+install='autocomplete-ALL-the-things.install'
+
+_gitroot="git://github.com/Vifon/autocomplete-ALL-the-things.git"
+_gitname="autocomplete-ALL-the-things"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ]; then
+ cd $_gitname && git pull origin --depth=1
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname --depth=1
+ fi
+
+ msg "GIT checkout done or server timeout"
+ rm -rf "$srcdir/$_gitname-build"
+ cp -r "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -D -m 644 "autocomplete-ALL-the-things" "$pkgdir/usr/lib/urxvt/perl/autocomplete-ALL-the-things"
+}
diff --git a/autocomplete-ALL-the-things.install b/autocomplete-ALL-the-things.install
new file mode 100644
index 000000000000..bb46217650a5
--- /dev/null
+++ b/autocomplete-ALL-the-things.install
@@ -0,0 +1,12 @@
+post_install ()
+{
+ echo "==> To enable autocomplete-ALL-the-things,"
+ echo "==> add the following to your ~/.Xresources (or ~/.Xdefaults):"
+ echo "==> URxvt.perl-ext-common: [your previous plugins],autocomplete-ALL-the-things"
+ echo "==> URxvt.keysym.M-slash: perl:aAtt:complete"
+}
+
+post_upgrade ()
+{
+ post_install $1
+}