summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2015-06-08 16:37:36 -0500
committerChristopher Luna2015-06-08 16:37:36 -0500
commit85b57172eca1639990f1dd29ef301ce6a914bd6a (patch)
tree47c9ff660238e1e4b25c268fdc41149e08300384
downloadaur-85b57172eca1639990f1dd29ef301ce6a914bd6a.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rw-r--r--fullscreen8
-rw-r--r--urxvt-fullscreen.install12
4 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..027d9c0d1da7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = urxvt-fullscreen
+ pkgdesc = script to switch fullscreen and above-other-windows on urxvt
+ pkgver = 1
+ pkgrel = 1
+ url = http://wiki.archlinux.org/index.php/Rxvt-unicode
+ install = urxvt-fullscreen.install
+ arch = any
+ license = GPL
+ depends = rxvt-unicode
+ depends = wmctrl
+ source = fullscreen
+ md5sums = 886bd05ab7931dbf019edd624b591378
+
+pkgname = urxvt-fullscreen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64e80903ba59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Contributor : chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
+
+pkgname="urxvt-fullscreen"
+pkgver=1
+pkgrel=1
+pkgdesc="script to switch fullscreen and above-other-windows on urxvt"
+arch=("any")
+depends=('rxvt-unicode' 'wmctrl')
+license=("GPL")
+url='http://wiki.archlinux.org/index.php/Rxvt-unicode'
+source=("fullscreen" )
+md5sums=('886bd05ab7931dbf019edd624b591378')
+install="$pkgname.install"
+
+package() {
+ install -Dm644 ${srcdir}/fullscreen ${pkgdir}/usr/lib/urxvt/perl/fullscreen
+}
diff --git a/fullscreen b/fullscreen
new file mode 100644
index 000000000000..8e492280865f
--- /dev/null
+++ b/fullscreen
@@ -0,0 +1,8 @@
+#! perl
+
+sub on_user_command {
+ my ($self, $cmd) = @_;
+ if ($cmd eq "fullscreen:switch") {
+ my $dummy = `wmctrl -r :ACTIVE: -b toggle,fullscreen,above` ;
+ }
+}
diff --git a/urxvt-fullscreen.install b/urxvt-fullscreen.install
new file mode 100644
index 000000000000..46deec79c2cf
--- /dev/null
+++ b/urxvt-fullscreen.install
@@ -0,0 +1,12 @@
+post_install ()
+{
+ echo "Add \"fullscreen\" to the \"urxvt*perl-ext-common\" field in ~/.Xdefaults and"
+ echo "a keysym to the function \"switch\", like: urxvt*keysym.F11: perl:fullscreen:switch"
+}
+
+post_remove ()
+{
+ echo "Don't forget to remove \"fullscreen\" from the \"urxvt*perl-ext-common\" field"
+ echo "and the keysym assigned to the fullscreen switch function in ~/.Xdefaults."
+}
+