summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-06-18 18:02:21 +0200
committeranthraxx2015-06-18 18:02:21 +0200
commit108b7ffbefcb15f83b3f5610899ba2fdd86f3250 (patch)
tree0bcf4119afeef8733fb06b25fc89c9f910832774
downloadaur-108b7ffbefcb15f83b3f5610899ba2fdd86f3250.tar.gz
addpkg: urxvt-resize-font-git 4.5336d3f-2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
-rw-r--r--urxvt-resize-font-git.install7
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eb9682ae9c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = urxvt-resize-font-git
+ pkgdesc = An urxvt plugin to adjust the font size on the fly
+ pkgver = 4.5336d3f
+ pkgrel = 2
+ url = https://github.com/simmel/urxvt-resize-font
+ install = urxvt-resize-font-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = rxvt-unicode
+ provides = urxvt-resize-font
+ conflicts = urxvt-resize-font
+ source = urxvt-resize-font-git::git+https://github.com/simmel/urxvt-resize-font.git
+ sha256sums = SKIP
+
+pkgname = urxvt-resize-font-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..287eda78311d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+# Contributor: Benjamin Frank <ben+aur@pipsfrank.de>
+
+pkgname=urxvt-resize-font-git
+_gitname=urxvt-resize-font
+pkgver=4.5336d3f
+pkgrel=2
+pkgdesc='An urxvt plugin to adjust the font size on the fly'
+arch=('any')
+url="https://github.com/simmel/urxvt-resize-font"
+license=('MIT')
+depends=('rxvt-unicode')
+makedepends=('git')
+provides=("urxvt-resize-font")
+conflicts=("urxvt-resize-font")
+install=urxvt-resize-font-git.install
+source=(${pkgname}::git+https://github.com/simmel/${_gitname}.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ head resize-font -n14|tail -n13 > LICENSE
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm 755 resize-font "${pkgdir}/usr/lib/urxvt/perl/resize-font"
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/urxvt-resize-font-git.install b/urxvt-resize-font-git.install
new file mode 100644
index 000000000000..4f1b1cde3b68
--- /dev/null
+++ b/urxvt-resize-font-git.install
@@ -0,0 +1,7 @@
+post_install() {
+ printf "\n %s\n\n" ">> No man page available, read /usr/share/doc/urxvt-resize-font-git/README.md"
+}
+
+post_upgrade() {
+ post_install $1
+}