summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryar2017-03-15 10:57:44 -0700
committeryar2017-03-15 12:38:28 -0700
commitd309febf4732c88fe06a8659e3d54b2b9ebf13c1 (patch)
treee2c7e68c3079b32cdfff315159618fe4b4d6c379
parent14b2b8f97186b45dd0dec9d2bf0adec699b55b21 (diff)
downloadaur-d309febf4732c88fe06a8659e3d54b2b9ebf13c1.tar.gz
use $gitname
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d33a2577c487..bb5eccb7f37d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,9 @@ pkgbase = urxvt-tabbedex-git
makedepends = git
depends = rxvt-unicode
provides = urxvt-tabbedex
+ provides = urxvt-tabbedex-git
conflicts = urxvt-tabbedex
+ conflicts = urxvt-tabbedex-git
source = git+https://github.com/mina86/urxvt-tabbedex.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ab1c07e6c453..df72015e1ac8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,26 @@
# Contributor: StephenB <mail4stb at gmail dot com>
# Contributor: M Rawash <mrawash@gmail.com>
-pkgname=urxvt-tabbedex-git
+gitname=urxvt-tabbedex
+pkgname=${gitname}-git
pkgver=0.4.r58.gac220eb
pkgrel=1
pkgdesc="A tabbed extension for rxvt-unicode with several enhancements"
arch=("any")
-url='https://github.com/mina86/urxvt-tabbedex'
+url="https://github.com/mina86/${gitname}"
license=("GPL")
depends=('rxvt-unicode')
makedepends=('git')
-provides=('urxvt-tabbedex')
-conflicts=('urxvt-tabbedex')
+provides=("${gitname}"{,-git})
+conflicts=("${gitname}"{,-git})
source=("git+${url}.git")
sha512sums=('SKIP')
pkgver() {
- cd urxvt-tabbedex
+ cd "${gitname}"
git describe --tags --long | sed 's/^tabbedex-//; s/-/-r/; s/-/./g'
}
package() {
- install -Dm644 urxvt-tabbedex/tabbedex "$pkgdir"/usr/lib/urxvt/perl/tabbedex
+ install -Dm644 "${gitname}/tabbedex" "${pkgdir}/usr/lib/urxvt/perl/tabbedex"
}