summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Beringer2017-03-10 00:11:29 +0100
committerIan Beringer2017-03-10 00:14:51 +0100
commitd6e2180f8caa7470b5bde8d1bf394385a53d5cc1 (patch)
treeeb864dc54c0c051f228db337b1850862ce136e10
parent59b465eab449a7bf93c710f9410d69184c4ae2d4 (diff)
downloadaur-d6e2180f8caa7470b5bde8d1bf394385a53d5cc1.tar.gz
Update to 0.6.2.r60.g14c1955
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--disable_usecase-tests.patch17
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c758516eeef..adebc6fc788a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = usbguard-git
pkgdesc = USBGuard is a software framework for implementing USB device authorization policies
- pkgver = 0.6.2.r43.gb28669d
+ pkgver = 0.6.2.r60.g14c1955
pkgrel = 1
url = https://github.com/dkopecek/usbguard
arch = i686
@@ -24,8 +24,10 @@ pkgbase = usbguard-git
backup = etc/usbguard/rules.conf
source = usbguard::git+https://github.com/dkopecek/usbguard.git
source = include.patch
+ source = disable_usecase-tests.patch
sha256sums = SKIP
sha256sums = 3a6ddb78a7f5c01a6a83c0a3337dd79a184ecb8a88d3adce1087e8beb4ca9c3f
+ sha256sums = 37d4e087b473c33b558724c9438ee26734243db707cc320385872f67e3db3bae
pkgname = usbguard-git
diff --git a/PKGBUILD b/PKGBUILD
index 46994f7aec8c..3f5439244716 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=usbguard-git
_pkgname=usbguard
-pkgver=0.6.2.r43.gb28669d
+pkgver=0.6.2.r60.g14c1955
pkgrel=1
license=('GPL2')
pkgdesc='USBGuard is a software framework for implementing USB device authorization policies'
@@ -10,8 +10,8 @@ makedepends=("git" "libxslt")
depends=("libqb-git" "libsodium" "libcap-ng" "protobuf" "polkit" "qt5-base" "qt5-svg" "qt5-tools" "hicolor-icon-theme" "dbus-glib")
arch=("i686" "x86_64")
url='https://github.com/dkopecek/usbguard'
-source=("${_pkgname}::git+https://github.com/dkopecek/usbguard.git" "include.patch")
-sha256sums=('SKIP' '3a6ddb78a7f5c01a6a83c0a3337dd79a184ecb8a88d3adce1087e8beb4ca9c3f')
+source=("${_pkgname}::git+https://github.com/dkopecek/usbguard.git" "include.patch" "disable_usecase-tests.patch")
+sha256sums=('SKIP' '3a6ddb78a7f5c01a6a83c0a3337dd79a184ecb8a88d3adce1087e8beb4ca9c3f' '37d4e087b473c33b558724c9438ee26734243db707cc320385872f67e3db3bae')
provides=("usbguard")
conflicts=("usbguard")
backup=(
@@ -30,6 +30,7 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
patch -p1 <../include.patch
+ patch -p1 <../disable_usecase-tests.patch
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc -sbindir=/usr/bin --libdir=/usr/lib \
--enable-systemd \
diff --git a/disable_usecase-tests.patch b/disable_usecase-tests.patch
new file mode 100644
index 000000000000..a891b35b4c15
--- /dev/null
+++ b/disable_usecase-tests.patch
@@ -0,0 +1,17 @@
+diff --git a/src/Tests/Makefile.am b/src/Tests/Makefile.am
+index 4543e32..b01d616 100644
+--- a/src/Tests/Makefile.am
++++ b/src/Tests/Makefile.am
+@@ -57,11 +57,7 @@ TESTS=\
+ test-regression \
+ USB/test-descriptor-parser.sh \
+ Packaging/spell-check.sh \
+- Rules/test-rules.sh \
+- UseCase/000_executable.sh \
+- UseCase/001_cli_policy.sh \
+- UseCase/002_cli_devices.sh \
+- UseCase/003_cli_devices_dummy.sh
++ Rules/test-rules.sh
+
+ check_PROGRAMS=\
+ test-unit \