summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-01 10:25:28 +1200
committercaltlgin2020-08-01 10:25:28 +1200
commit4e4bcaf4a7d2664c8517b4cc19a06aa3be48ccd0 (patch)
tree5f945795a47443f4bad9dc9ebd5c3da6dfede25a
downloadaur-4e4bcaf4a7d2664c8517b4cc19a06aa3be48ccd0.tar.gz
Add to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70a8d637cf2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = usbimager-bin
+ pkgdesc = Minimal GUI application to write compressed disk images to USB drives
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://gitlab.com/bztsrc/usbimager
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = udisks2
+ source = usbimager-1.0.4.zip::https://gitlab.com/bztsrc/usbimager/-/raw/binaries/usbimager_1.0.4-x86_64-linux-gtk.zip
+ source = usbimager-1.0.4-manual.pdf::https://gitlab.com/bztsrc/usbimager/-/raw/master/usbimager-manual.pdf
+ source = usbimager-1.0.4-LICENSE::https://gitlab.com/bztsrc/usbimager/-/raw/master/LICENSE
+ sha256sums = 49a11062ac722236c2f265358b96ffaad803e530ff5c7192e68d329564f8ba66
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = usbimager-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44a08eb9ad49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=usbimager
+pkgname=${_pkgname}-bin
+pkgver=1.0.4
+pkgrel=1
+pkgdesc='Minimal GUI application to write compressed disk images to USB drives'
+arch=('x86_64')
+url='https://gitlab.com/bztsrc/usbimager'
+license=('MIT')
+depends=('gtk3' 'udisks2')
+source=("${_pkgname}-${pkgver}.zip::${url}/-/raw/binaries/${_pkgname}_${pkgver}-x86_64-linux-gtk.zip"
+ "${_pkgname}-${pkgver}-manual.pdf::${url}/-/raw/master/usbimager-manual.pdf"
+ "${_pkgname}-${pkgver}-LICENSE::${url}/-/raw/master/LICENSE")
+sha256sums=('49a11062ac722236c2f265358b96ffaad803e530ff5c7192e68d329564f8ba66'
+ 'SKIP'
+ 'SKIP')
+
+package() {
+ install -Dm644 "${_pkgname}-${pkgver}-manual.pdf" "${pkgdir}/usr/share/doc/${_pkgname}/manual.pdf"
+ install -Dm644 "${_pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm755 "bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "share/applications/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "share/man/man8/${_pkgname}.8.gz" "${pkgdir}/usr/share/man/man8/${_pkgname}.8.gz"
+ cp -r 'share/icons' "${pkgdir}/usr/share"
+}
+
+# vim: ts=2 sw=2 et: