summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeoTheFox2020-06-24 14:35:41 +0300
committerNeoTheFox2020-06-24 14:35:41 +0300
commit1ca2d5a1c5b8bebe1d22d717d15b01751003ef4c (patch)
tree5840f420c06ab6190cd86ae41a2668be5c3522c8
downloadaur-1ca2d5a1c5b8bebe1d22d717d15b01751003ef4c.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--usbimager-git.install8
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ebb94099775
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = usbimager-git
+ pkgdesc = USBImager is a really really simple GUI application that writes compressed disk images to USB drives and creates backups.
+ pkgver = 1.0.4.r0.g1cfeeb8
+ pkgrel = 1
+ url = https://gitlab.com/bztsrc/usbimager
+ install = usbimager-git.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ depends = libx11
+ depends = libxdmcp
+ depends = libxcb
+ provides = usbimager
+ conflicts = usbimager
+ source = usbimager-git::git+https://gitlab.com/bztsrc/usbimager.git
+ md5sums = SKIP
+
+pkgname = usbimager-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3358fffffc34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=usbimager-git
+pkgver=1.0.4.r0.g1cfeeb8
+pkgrel=1
+pkgdesc="USBImager is a really really simple GUI application that writes compressed disk images to USB drives and creates backups."
+arch=('i686' 'x86_64' 'armv7h')
+url="https://gitlab.com/bztsrc/usbimager"
+license=('MIT')
+depends=('libx11' 'libxdmcp' 'libxcb')
+makedepends=('git')
+conflicts=('usbimager')
+provides=('usbimager')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'git+https://gitlab.com/bztsrc/usbimager.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+install="${pkgname}.install"
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname/src"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/src"
+ mkdir -p $pkgdir/usr/bin
+ make PREFIX=/usr DESTDIR=$pkgdir install
+}
diff --git a/usbimager-git.install b/usbimager-git.install
new file mode 100644
index 000000000000..b7b7e2b72c21
--- /dev/null
+++ b/usbimager-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo
+ echo "==> In oder to use usbimager you have to be a member of the disk group"
+ echo "==> if you aren't run"
+ echo "==> sudo gpasswd -a $USER disk"
+ echo "==> and re-login"
+ echo
+}