summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeoTheFox2020-06-24 14:56:47 +0300
committerNeoTheFox2020-06-24 14:56:47 +0300
commit8bdcf4a60785ac03177431db4518ca4577fb281b (patch)
tree3669dd888ef5076ee279bd1f464214a911500c58
parent1ca2d5a1c5b8bebe1d22d717d15b01751003ef4c (diff)
downloadaur-8bdcf4a60785ac03177431db4518ca4577fb281b.tar.gz
added build options
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
-rw-r--r--usbimager-git.install2
3 files changed, 24 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ebb94099775..cb1371dd2070 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = usbimager-git
pkgdesc = USBImager is a really really simple GUI application that writes compressed disk images to USB drives and creates backups.
pkgver = 1.0.4.r0.g1cfeeb8
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/bztsrc/usbimager
install = usbimager-git.install
arch = i686
@@ -12,6 +12,11 @@ pkgbase = usbimager-git
depends = libx11
depends = libxdmcp
depends = libxcb
+ optdepends = gtk3
+ optdepends = pango
+ optdepends = harfbuzz
+ optdepends = gdk-pixbuf2
+ optdepends = udisks2
provides = usbimager
conflicts = usbimager
source = usbimager-git::git+https://gitlab.com/bztsrc/usbimager.git
diff --git a/PKGBUILD b/PKGBUILD
index 3358fffffc34..097aff826559 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,26 @@
+##
+## The following variables can be customized at build time. Use env or export to change at your wish
+##
+## Example: env USE_LIBUI=yes USE_UDISKS2=yes makepkg -sc
+##
+## Should GTK3 be used
+if [ -z ${USE_LIBUI+x} ]; then
+ USE_LIBUI=no
+fi
+## Should UDISKS2 be used
+if [ -z ${USE_UDISKS2+x} ]; then
+ USE_UDISKS2=no
+fi
+
pkgname=usbimager-git
pkgver=1.0.4.r0.g1cfeeb8
-pkgrel=1
+pkgrel=2
pkgdesc="USBImager is a really really simple GUI application that writes compressed disk images to USB drives and creates backups."
arch=('i686' 'x86_64' 'armv7h')
url="https://gitlab.com/bztsrc/usbimager"
license=('MIT')
depends=('libx11' 'libxdmcp' 'libxcb')
+optdepends=('gtk3' 'pango' 'harfbuzz' 'gdk-pixbuf2' 'udisks2')
makedepends=('git')
conflicts=('usbimager')
provides=('usbimager')
@@ -25,6 +40,7 @@ pkgver() {
build() {
cd "$srcdir/$pkgname/src"
+
make
}
diff --git a/usbimager-git.install b/usbimager-git.install
index b7b7e2b72c21..ba85de692d15 100644
--- a/usbimager-git.install
+++ b/usbimager-git.install
@@ -1,7 +1,7 @@
post_install() {
echo
echo "==> In oder to use usbimager you have to be a member of the disk group"
- echo "==> if you aren't run"
+ echo "==> Alternatively, you can try buidling with UDISKS2 support. To add a group run"
echo "==> sudo gpasswd -a $USER disk"
echo "==> and re-login"
echo