summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2021-01-07 06:02:05 +1300
committercaltlgin2021-01-07 06:02:05 +1300
commit7095c029f48f36733c0a6777cbb0085eaecf1ffa (patch)
treead26960ac34faab5e8b527ed14f2e414a114577e
parentf6777b80d8990e9e7929314a5c43b39dd7656efb (diff)
downloadaur-7095c029f48f36733c0a6777cbb0085eaecf1ffa.tar.gz
Update to v1.0.6
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
-rw-r--r--makefile.patch15
4 files changed, 40 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4965a252bd45..168e3242119f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = usbimager-x11
pkgdesc = Minimal GUI application to write compressed disk images to USB drives (X11 Frontend)
- pkgver = 1.0.5
+ pkgver = 1.0.6
pkgrel = 1
url = https://gitlab.com/bztsrc/usbimager
arch = x86_64
arch = armv7h
arch = aarch64
license = MIT
+ makedepends = setconf
depends = hicolor-icon-theme
depends = libx11
provides = usbimager
conflicts = usbimager
- source = https://gitlab.com/bztsrc/usbimager/-/archive/1.0.5/usbimager-1.0.5.tar.gz
- sha256sums = 20ffc3720f4c806285628064d536cbf5a59f05d6fdef92bd06f9fbd694426ce6
+ source = https://gitlab.com/bztsrc/usbimager/-/archive/1.0.6/usbimager-1.0.6.tar.gz
+ source = makefile.patch
+ sha256sums = 1d436524c46d756bd4ab598929b41e6d8dc6d23e11c8576667cb44999e6e87b8
+ sha256sums = a8622b5584d5458b608096f24ab2e52e40f1970baaf4e4cd1ffd69b64d149828
pkgname = usbimager-x11
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..13ae487c6184
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!makefile.patch
diff --git a/PKGBUILD b/PKGBUILD
index 5dfa3cfce783..98b223ed2bbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
_pkgname='usbimager'
pkgname="${_pkgname}-x11"
-pkgver=1.0.5
+pkgver=1.0.6
pkgrel=1
pkgdesc='Minimal GUI application to write compressed disk images to USB drives (X11 Frontend)'
arch=('x86_64' 'armv7h' 'aarch64')
url='https://gitlab.com/bztsrc/usbimager'
license=('MIT')
depends=('hicolor-icon-theme' 'libx11')
+makedepends=('setconf')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('20ffc3720f4c806285628064d536cbf5a59f05d6fdef92bd06f9fbd694426ce6')
+source=("${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ 'makefile.patch')
+sha256sums=('1d436524c46d756bd4ab598929b41e6d8dc6d23e11c8576667cb44999e6e87b8'
+ 'a8622b5584d5458b608096f24ab2e52e40f1970baaf4e4cd1ffd69b64d149828')
prepare() {
- # Add LDFLAGS to Makefile
- sed -i "/LDFLAGS =/s/$/ ${LDFLAGS}/" "${_pkgname}-${pkgver}/src/Makefile"
- # Skip chgrp and chmod operations in Makefile
- sed -i '160s/ifneq/ifeq/' "${_pkgname}-${pkgver}/src/Makefile"
+ cd "${_pkgname}-${pkgver}"
+ setconf 'src/Makefile' 'LDFLAGS' "${LDFLAGS}" # Add LDFLAGS to Makefile
+ patch --forward --strip=1 --input="${srcdir}/makefile.patch" # Skip chgrp and chmod operations in Makefile
}
build() {
@@ -27,14 +29,14 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
- install -Dm755 "src/${_pkgname}" -t "${pkgdir}/usr/bin"
- install -Dm644 "src/misc/${_pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dvm755 "src/${_pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dvm644 "src/misc/${_pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
for i in 16 32 64 128; do
install -Dvm644 "src/misc/icon${i}.png" "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/${_pkgname}.png"
done
- install -Dm644 "src/misc/${_pkgname}.8.gz" -t "${pkgdir}/usr/share/man/man8"
- install -Dm644 {'README.md',"${_pkgname}-manual.pdf"} -t "${pkgdir}/usr/share/doc/${_pkgname}"
- install -Dm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -Dvm644 "src/misc/${_pkgname}.8.gz" -t "${pkgdir}/usr/share/man/man8"
+ install -Dvm644 {'README.md',"${_pkgname}-manual.pdf"} -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}
# vim: ts=2 sw=2 et:
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..5ecd9e64c27f
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,15 @@
+diff --unified --recursive --text usbimager-orig/src/Makefile usbimager-new/src/Makefile
+--- usbimager-orig/src/Makefile 2020-09-23 07:19:31.000000000 +1200
++++ usbimager-new/src/Makefile 2020-11-30 07:46:07.134100297 +1300
+@@ -157,11 +157,6 @@
+ ifeq ($(DEBUG),)
+ $(STRIP) $(TARGET)
+ endif
+-ifneq ($(GRP),)
+- chgrp $(GRP) $(TARGET) || true
+- chmod g+s $(TARGET) || true
+- @(ls -la $(TARGET)|grep $(GRP)|grep sr) || printf "\n\nWARNING - Your user is not member of the '$(GRP)' group, can't grant access. Run the following two commands manually:\n\n sudo chgrp $(GRP) $(TARGET)\n sudo chmod g+s $(TARGET)\n\n"
+-endif
+
+ ####### install and package creation #######
+