summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-11 17:54:49 +1300
committercaltlgin2020-10-11 17:54:49 +1300
commitf6777b80d8990e9e7929314a5c43b39dd7656efb (patch)
treeadf3fc993f5871bedb0633713e8c59d49bbe96ff
downloadaur-f6777b80d8990e9e7929314a5c43b39dd7656efb.tar.gz
Add to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4965a252bd45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = usbimager-x11
+ pkgdesc = Minimal GUI application to write compressed disk images to USB drives (X11 Frontend)
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://gitlab.com/bztsrc/usbimager
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ depends = hicolor-icon-theme
+ depends = libx11
+ provides = usbimager
+ conflicts = usbimager
+ source = https://gitlab.com/bztsrc/usbimager/-/archive/1.0.5/usbimager-1.0.5.tar.gz
+ sha256sums = 20ffc3720f4c806285628064d536cbf5a59f05d6fdef92bd06f9fbd694426ce6
+
+pkgname = usbimager-x11
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dfa3cfce783
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='usbimager'
+pkgname="${_pkgname}-x11"
+pkgver=1.0.5
+pkgrel=1
+pkgdesc='Minimal GUI application to write compressed disk images to USB drives (X11 Frontend)'
+arch=('x86_64' 'armv7h' 'aarch64')
+url='https://gitlab.com/bztsrc/usbimager'
+license=('MIT')
+depends=('hicolor-icon-theme' 'libx11')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('20ffc3720f4c806285628064d536cbf5a59f05d6fdef92bd06f9fbd694426ce6')
+
+prepare() {
+ # Add LDFLAGS to Makefile
+ sed -i "/LDFLAGS =/s/$/ ${LDFLAGS}/" "${_pkgname}-${pkgver}/src/Makefile"
+ # Skip chgrp and chmod operations in Makefile
+ sed -i '160s/ifneq/ifeq/' "${_pkgname}-${pkgver}/src/Makefile"
+}
+
+build() {
+ make -C "${_pkgname}-${pkgver}/src"
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ install -Dm755 "src/${_pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "src/misc/${_pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ for i in 16 32 64 128; do
+ install -Dvm644 "src/misc/icon${i}.png" "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/${_pkgname}.png"
+ done
+ install -Dm644 "src/misc/${_pkgname}.8.gz" -t "${pkgdir}/usr/share/man/man8"
+ install -Dm644 {'README.md',"${_pkgname}-manual.pdf"} -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: