summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgmes782017-07-22 21:34:19 +0100
committergmes782017-07-22 21:34:19 +0100
commit7d6ffc888bd1f0b458857742f210f1e084247d76 (patch)
tree35a266d4792b577f4213e32791e8c43d34b411f5
downloadaur-7d6ffc888bd1f0b458857742f210f1e084247d76.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD51
-rw-r--r--usbmaker.desktop8
-rw-r--r--usbmaker.pkexec.policy20
-rw-r--r--usbmaker.svg104
-rwxr-xr-xusbmaker_polkit6
6 files changed, 224 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5793fe48f949
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = usbmaker
+ pkgdesc = Utility to format and make bootable usb drives
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/gmes/USBMaker
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-pyqt5
+ optdepends = parted: partitioning support
+ optdepends = cdrtools: ISO label detection
+ optdepends = e2fsprogs: Ext4 and badblocks support
+ optdepends = dosfstools: FAT support
+ optdepends = exfat-utils: exFAT support
+ optdepends = ntfs-3g: NTFS support
+ optdepends = udftools: UDF support
+ optdepends = btrfs-progs: Btrfs support
+ optdepends = grub: GRUB2 support
+ optdepends = syslinux: SYSLINUX support
+ optdepends = systemd: systemd-boot support
+ optdepends = grub4dos: GRUB4DOS support
+ conflicts = usbmaker-git
+ source = https://github.com/gmes/USBMaker/archive/1.0.1.tar.gz
+ source = usbmaker.desktop
+ source = usbmaker.svg
+ source = usbmaker_polkit
+ source = usbmaker.pkexec.policy
+ sha512sums = a180e6e0e0dfd2de69d35e0f4e5e3d4cd6d03534bcf1f0eae16142aac1c4a8ba0e4f631d849b1d928fe4ead7ac7522f03111b299ce823f8b1a493823d6f945df
+ sha512sums = 0390d0b242952a96b61e576d9ec8dbfa2db5f53443e46d0d646d3be4f9da9245446b423595dbdd290c9787bbd50f728ad5abe47199d975029e68ca30ced91c9a
+ sha512sums = 31c1959750310f2b657c46e0c6b660c720c5fc135bf096845935756126db426d0cd0232b14a58cab057ebee5bf1e707e3680f61d9d398cdde14550b5de498c6b
+ sha512sums = 4c3b6f727ebbc728e0127d487077b7e03497ebcf3781bf52ca982114989d7a05347ffd8a479eeb05851b0cd5ec879f0ce0e9792d79c9d1621382595a87de7ab1
+ sha512sums = 9847ca9775c85b60b023d4fb03ecb4a80286b160d9fdbca0535d58568b06784d5e2c6e7bc649a97c9fafa740f5b6023aa50f6e2f1ca80649c998fbf2792fbd84
+
+pkgname = usbmaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4d3e32c1f15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: gmes78 <gmes.078 at gmail dot com>
+pkgname=usbmaker
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Utility to format and make bootable usb drives"
+arch=(any)
+url="https://github.com/gmes/USBMaker"
+license=('GPL')
+depends=('python-pyqt5')
+makedepends=('python-setuptools')
+optdepends=('parted: partitioning support'
+ 'cdrtools: ISO label detection'
+ 'e2fsprogs: Ext4 and badblocks support'
+ 'dosfstools: FAT support'
+ 'exfat-utils: exFAT support'
+ 'ntfs-3g: NTFS support'
+ 'udftools: UDF support'
+ 'btrfs-progs: Btrfs support'
+ 'grub: GRUB2 support'
+ 'syslinux: SYSLINUX support'
+ 'systemd: systemd-boot support'
+ 'grub4dos: GRUB4DOS support')
+conflicts=('usbmaker-git')
+source=("https://github.com/gmes/USBMaker/archive/$pkgver.tar.gz"
+ 'usbmaker.desktop'
+ 'usbmaker.svg'
+ 'usbmaker_polkit'
+ 'usbmaker.pkexec.policy')
+sha512sums=('a180e6e0e0dfd2de69d35e0f4e5e3d4cd6d03534bcf1f0eae16142aac1c4a8ba0e4f631d849b1d928fe4ead7ac7522f03111b299ce823f8b1a493823d6f945df'
+ '0390d0b242952a96b61e576d9ec8dbfa2db5f53443e46d0d646d3be4f9da9245446b423595dbdd290c9787bbd50f728ad5abe47199d975029e68ca30ced91c9a'
+ '31c1959750310f2b657c46e0c6b660c720c5fc135bf096845935756126db426d0cd0232b14a58cab057ebee5bf1e707e3680f61d9d398cdde14550b5de498c6b'
+ '4c3b6f727ebbc728e0127d487077b7e03497ebcf3781bf52ca982114989d7a05347ffd8a479eeb05851b0cd5ec879f0ce0e9792d79c9d1621382595a87de7ab1'
+ '9847ca9775c85b60b023d4fb03ecb4a80286b160d9fdbca0535d58568b06784d5e2c6e7bc649a97c9fafa740f5b6023aa50f6e2f1ca80649c998fbf2792fbd84')
+
+package() {
+ cd "$srcdir/USBMaker-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ mkdir -p "$pkgdir/usr/share/applications"
+ install --mode=644 --owner=root --group=root "$srcdir/usbmaker.desktop" "$pkgdir/usr/share/applications/"
+
+ mkdir -p "$pkgdir/usr/share/icons"
+ install --mode=644 --owner=root --group=root "$srcdir/usbmaker.svg" "$pkgdir/usr/share/icons/"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install --mode=755 --owner=root --group=root "$srcdir/usbmaker_polkit" "$pkgdir/usr/bin/"
+
+ mkdir -p "$pkgdir/usr/share/polkit-1/actions"
+ install --mode=644 --owner=root --group=root "$srcdir/usbmaker.pkexec.policy" "$pkgdir/usr/share/polkit-1/actions/"
+}
diff --git a/usbmaker.desktop b/usbmaker.desktop
new file mode 100644
index 000000000000..9d09f8bf87f8
--- /dev/null
+++ b/usbmaker.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=USBMaker
+GenericName=Bootable USB creator
+Icon=usbmaker
+Exec=usbmaker_polkit
+Terminal=false
+Categories=Utility;Qt
diff --git a/usbmaker.pkexec.policy b/usbmaker.pkexec.policy
new file mode 100644
index 000000000000..8e3537ad199d
--- /dev/null
+++ b/usbmaker.pkexec.policy
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE policyconfig PUBLIC
+ "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
+<policyconfig>
+
+ <action id="usbmaker.pkexec">
+ <message>Authentication is required to run USBMaker</message>
+ <icon_name>usbmaker</icon_name>
+ <defaults>
+ <allow_any>auth_admin</allow_any>
+ <allow_inactive>auth_admin</allow_inactive>
+ <allow_active>auth_admin</allow_active>
+ </defaults>
+ <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/usbmaker</annotate>
+ <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
+ </action>
+
+</policyconfig>
+
diff --git a/usbmaker.svg b/usbmaker.svg
new file mode 100644
index 000000000000..a1cb29987360
--- /dev/null
+++ b/usbmaker.svg
@@ -0,0 +1,104 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ viewBox="0 0 48 48"
+ version="1.1"
+ id="svg33894"
+ sodipodi:docname="usbmaker.svg"
+ inkscape:version="0.92.1 r">
+ <metadata
+ id="metadata33898">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <sodipodi:namedview
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1"
+ objecttolerance="10"
+ gridtolerance="10"
+ guidetolerance="10"
+ inkscape:pageopacity="0"
+ inkscape:pageshadow="2"
+ inkscape:window-width="1920"
+ inkscape:window-height="1011"
+ id="namedview33896"
+ showgrid="false"
+ inkscape:zoom="7.465116"
+ inkscape:cx="-2.5823494"
+ inkscape:cy="17.923556"
+ inkscape:window-x="0"
+ inkscape:window-y="0"
+ inkscape:window-maximized="1"
+ inkscape:current-layer="svg33894">
+ <inkscape:grid
+ type="xygrid"
+ id="grid33953" />
+ </sodipodi:namedview>
+ <defs
+ id="defs33848">
+ <linearGradient
+ id="linearGradient3764"
+ x1="1"
+ x2="47"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0,-1,1,0,-1.5e-6,47.999998)">
+ <stop
+ style="stop-color:#d3d3d3;stop-opacity:1"
+ id="stop33843" />
+ <stop
+ offset="1"
+ style="stop-color:#ddd;stop-opacity:1"
+ id="stop33845" />
+ </linearGradient>
+ </defs>
+ <g
+ id="g33856">
+ <path
+ d="m 36.31 5 c 5.859 4.062 9.688 10.831 9.688 18.5 c 0 12.426 -10.07 22.5 -22.5 22.5 c -7.669 0 -14.438 -3.828 -18.5 -9.688 c 1.037 1.822 2.306 3.499 3.781 4.969 c 4.085 3.712 9.514 5.969 15.469 5.969 c 12.703 0 23 -10.298 23 -23 c 0 -5.954 -2.256 -11.384 -5.969 -15.469 c -1.469 -1.475 -3.147 -2.744 -4.969 -3.781 z m 4.969 3.781 c 3.854 4.113 6.219 9.637 6.219 15.719 c 0 12.703 -10.297 23 -23 23 c -6.081 0 -11.606 -2.364 -15.719 -6.219 c 4.16 4.144 9.883 6.719 16.219 6.719 c 12.703 0 23 -10.298 23 -23 c 0 -6.335 -2.575 -12.06 -6.719 -16.219 z"
+ style="opacity:0.05"
+ id="path33850" />
+ <path
+ d="m 41.28 8.781 c 3.712 4.085 5.969 9.514 5.969 15.469 c 0 12.703 -10.297 23 -23 23 c -5.954 0 -11.384 -2.256 -15.469 -5.969 c 4.113 3.854 9.637 6.219 15.719 6.219 c 12.703 0 23 -10.298 23 -23 c 0 -6.081 -2.364 -11.606 -6.219 -15.719 z"
+ style="opacity:0.1"
+ id="path33852" />
+ <path
+ d="m 31.25 2.375 c 8.615 3.154 14.75 11.417 14.75 21.13 c 0 12.426 -10.07 22.5 -22.5 22.5 c -9.708 0 -17.971 -6.135 -21.12 -14.75 a 23 23 0 0 0 44.875 -7 a 23 23 0 0 0 -16 -21.875 z"
+ style="opacity:0.2"
+ id="path33854" />
+ </g>
+ <g
+ id="g33860">
+ <path
+ d="m 24 1 c 12.703 0 23 10.297 23 23 c 0 12.703 -10.297 23 -23 23 -12.703 0 -23 -10.297 -23 -23 0 -12.703 10.297 -23 23 -23 z"
+ style="fill:url(#linearGradient3764);fill-opacity:1"
+ id="path33858" />
+ </g>
+ <g
+ id="g33892">
+ <path
+ d="m 40.03 7.531 c 3.712 4.084 5.969 9.514 5.969 15.469 0 12.703 -10.297 23 -23 23 c -5.954 0 -11.384 -2.256 -15.469 -5.969 4.178 4.291 10.01 6.969 16.469 6.969 c 12.703 0 23 -10.298 23 -23 0 -6.462 -2.677 -12.291 -6.969 -16.469 z"
+ style="opacity:0.1"
+ id="path33890" />
+ </g>
+ <path
+ id="path1334"
+ d="m 37.873843,9.076969 -5.023265,1.345405 1.311803,1.311803 -16.27602,16.276022 -0.179082,-6.517333 c 0.05352,-0.485888 0.254749,-0.990423 0.609349,-1.361824 1.468483,-1.468484 2.340156,-2.340919 2.660545,-2.662526 0.837498,0.40233 1.869415,0.265314 2.564231,-0.429503 0.87899,-0.878991 0.879055,-2.3056 -2.54e-4,-3.184908 -0.879691,-0.879691 -2.305982,-0.879436 -3.185036,-3.82e-4 -0.694817,0.694817 -0.832088,1.726479 -0.430267,2.563467 l -2.630797,2.629907 c -0.712891,0.712891 -1.068764,1.851022 -1.085692,2.784997 -6.36e-4,-0.0266 -0.0017,-0.0546 -5.23e-4,10e-4 0.0013,0.02138 0.189646,6.914316 0.189646,6.914316 -0.05327,0.484998 -0.255259,0.988387 -0.609349,1.359788 l -1.841222,1.841221 c -1.460401,-0.972286 -3.450921,-0.814587 -4.7393691,0.473861 -1.468993,1.468993 -1.468993,3.850514 -4.455e-4,5.319062 1.4689936,1.468993 3.8505786,1.469057 5.3195716,6.3e-5 C 15.816369,36.452703 15.973305,34.46142 15,33 l 1.808956,-1.808956 c 0.0047,-0.0047 0.0095,-0.009 0.014,-0.014 l 4.001085,-4.001086 c 0.371274,-0.352818 0.874409,-0.554173 1.359406,-0.606931 0,0 6.891915,0.188883 6.913743,0.189965 0.0553,0.0016 0.02711,1.27e-4 5.09e-4,0 0.933911,-0.01699 2.072106,-0.373438 2.785124,-1.086456 l 2.534321,-2.535466 1.067681,1.067682 3.185163,-3.185163 -3.184844,-3.184844 -3.185162,3.185163 1.066282,1.066282 c 0,0 -0.668846,0.666441 -2.567152,2.564747 -0.3714,0.354727 -0.876126,0.556528 -1.361887,0.609922 l -6.518668,-0.178988 12.295745,-12.295745 1.313904,1.313903 z"
+ inkscape:connector-curvature="0"
+ style="stroke-width:0.09;fill:#201f1f"
+ inkscape:transform-center-x="-15.279541"
+ inkscape:transform-center-y="-14.878946" />
+</svg>
diff --git a/usbmaker_polkit b/usbmaker_polkit
new file mode 100755
index 000000000000..87bddf885f1e
--- /dev/null
+++ b/usbmaker_polkit
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [ $(which pkexec) ]; then
+ pkexec --disable-internal-agent "/usr/bin/usbmaker" "$@"
+else
+ /usr/bin/usbmaker "$@"
+fi