summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelmur2018-08-05 12:26:40 +0200
committerfelmur2018-08-05 12:26:40 +0200
commit24f3333d9f48c996e86efacc1f410ef38fa7dcc4 (patch)
tree54aadf3e77262b6b477b0215a6f76ef3e7150cd9
downloadaur-24f3333d9f48c996e86efacc1f410ef38fa7dcc4.tar.gz
First AUR version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..303a0d932838
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = usbrelay
+ pkgdesc = Control usb relay - based on hidapi
+ pkgver = 20180805
+ pkgrel = 1
+ url = https://github.com/darrylb123/usbrelay
+ arch = i686
+ arch = x86_64
+ groups = system
+ license = GPL-2.0
+ depends = hidapi
+ source = https://github.com/darrylb123/usbrelay/archive/master.zip
+ md5sums = 2291c1c5e92315d0d9e8804bfba4be6d
+
+pkgname = usbrelay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6713805d9c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Your Name <linuxboy@fel.hopto.org>
+pkgname=usbrelay
+pkgver=20180805
+pkgrel=1
+pkgdesc="Control usb relay - based on hidapi"
+url="https://github.com/darrylb123/usbrelay"
+license=('GPL-2.0')
+groups=('system')
+depends=('hidapi')
+arch=('i686' 'x86_64')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/darrylb123/usbrelay/archive/master.zip")
+noextract=()
+md5sums=('2291c1c5e92315d0d9e8804bfba4be6d')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-master"
+}
+
+build() {
+ cd "$pkgname-master"
+ make
+}
+
+
+package() {
+ cd "$pkgname-master"
+ make DESTDIR="$pkgdir/" install
+}