summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2018-06-12 13:19:43 +0200
committerSebastiaan Lokhorst2018-06-12 13:19:43 +0200
commit4afe0d1145b770ed4c6fe3da5eb72bd28d972698 (patch)
treefc556697893fa71c4409271e5b82209ce196eaec
parentedb3b3d0270e4482a830cd978202a5e09b67ebb7 (diff)
downloadaur-4afe0d1145b770ed4c6fe3da5eb72bd28d972698.tar.gz
Fix build with Boost 1.67
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d87b8e4a6785..8a730b3d69ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Dec 17 23:37:46 UTC 2017
pkgbase = usbtop
pkgdesc = top-like utility that shows an estimated instantaneous bandwidth on USB buses and devices
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/aguinet/usbtop
arch = x86_64
license = BSD
@@ -12,7 +10,9 @@ pkgbase = usbtop
depends = boost-libs
depends = libpcap
source = https://github.com/aguinet/usbtop/archive/release-0.2.tar.gz
+ source = https://github.com/aguinet/usbtop/pull/15.patch
sha256sums = 6283454ccbfecab44276344b6bc1bf74e86808fb9f539ca63eb0447d7741487e
+ sha256sums = 41cdf78a74a0f6f5ef367a75a24757ab9278a04e955bf57e9e51013ed58c6688
pkgname = usbtop
diff --git a/PKGBUILD b/PKGBUILD
index 0581212840a3..b5dc21752267 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,22 @@
# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
pkgname=usbtop
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="top-like utility that shows an estimated instantaneous bandwidth on USB buses and devices"
arch=('x86_64')
url="https://github.com/aguinet/usbtop"
license=('BSD')
depends=('boost-libs' 'libpcap')
makedepends=('boost' 'cmake')
-source=("$url/archive/release-$pkgver.tar.gz")
-sha256sums=('6283454ccbfecab44276344b6bc1bf74e86808fb9f539ca63eb0447d7741487e')
+source=("$url/archive/release-$pkgver.tar.gz"
+ "$url/pull/15.patch")
+sha256sums=('6283454ccbfecab44276344b6bc1bf74e86808fb9f539ca63eb0447d7741487e'
+ '41cdf78a74a0f6f5ef367a75a24757ab9278a04e955bf57e9e51013ed58c6688')
+
+prepare() {
+ cd "$pkgname-release-$pkgver"
+ patch -Np1 -i ../15.patch
+}
build() {
cd "$pkgname-release-$pkgver"