summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2017-11-27 13:46:45 -0800
committerSean Greenslade2017-11-27 13:46:45 -0800
commit2f55b3fb80cf358b0cfa8cfcd7926b1e029909e0 (patch)
tree61582a09e8e9801097ad0e60af849a247971353a
downloadaur-2f55b3fb80cf358b0cfa8cfcd7926b1e029909e0.tar.gz
Git version of usbtop.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b746581d7710
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Nov 27 21:46:37 UTC 2017
+pkgbase = usbtop-git
+ pkgdesc = top-like utility that shows an estimated instantaneous bandwidth on USB buses and devices
+ pkgver = 0.1.5.g07c8818
+ pkgrel = 1
+ url = https://github.com/aguinet/usbtop
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = boost
+ makedepends = cmake
+ depends = boost-libs
+ depends = libpcap
+ provides = usbtop
+ conflicts = usbtop
+ source = git+https://github.com/aguinet/usbtop.git
+ sha256sums = SKIP
+
+pkgname = usbtop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d4550dfdb1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Maintainer: Sean Greenslade <aur@seangreenslade.com>
+pkgname=usbtop-git
+pkgver=0.1.5.g07c8818
+pkgrel=1
+pkgdesc="top-like utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+arch=('i686' 'x86_64')
+url="https://github.com/aguinet/usbtop"
+license=('BSD')
+depends=('boost-libs' 'libpcap')
+provides=('usbtop')
+conflicts=('usbtop')
+makedepends=('boost' 'cmake')
+source=("git+https://github.com/aguinet/usbtop.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd usbtop
+ git describe --tags | sed 's/release-//g' | sed 's/-/./g'
+}
+
+build() {
+ cd usbtop
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" .
+ make
+}
+
+package() {
+ cd usbtop
+ make DESTDIR="$pkgdir/" install
+ mv "$pkgdir/usr/sbin" "$pkgdir/usr/bin"
+}