summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-11 15:09:53 -0500
committerVincent Grande2021-01-11 15:09:53 -0500
commit07a1beea4a5a9021d42afdf8b2fcceee1759982b (patch)
treed912b9d01e32c32a8fa4d603aaa752835930ae81
downloadaur-07a1beea4a5a9021d42afdf8b2fcceee1759982b.tar.gz
initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be5ad416c073
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = usbutils-git
+ pkgdesc = A collection of USB tools to query connected USB devices
+ pkgver = 013
+ pkgrel = 1
+ url = https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/
+ arch = x86_64
+ license = GPL2
+ makedepends = libusb
+ depends = glibc
+ depends = hwids
+ optdepends = python: for lsusb.py usage
+ optdepends = coreutils: for lsusb.py usage
+ provides = usbutils
+ conflicts = usbutils
+ source = git+https://github.com/gregkh/usbutils
+ b2sums = SKIP
+
+pkgname = usbutils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c86ce5da2c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: David Runge <dvzrv@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: Curtis Campbell <curtisjamescampbell@hotmail.com>
+
+pkgname=usbutils-git
+pkgver=013
+pkgrel=1
+pkgdesc="A collection of USB tools to query connected USB devices"
+arch=('x86_64')
+url="https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
+license=('GPL2')
+depends=('glibc' 'hwids')
+makedepends=('libusb')
+optdepends=('python: for lsusb.py usage'
+ 'coreutils: for lsusb.py usage')
+provides=(usbutils)
+conflicts=(usbutils)
+source=("git+https://github.com/gregkh/usbutils")
+b2sums=('SKIP')
+#validpgpkeys=('647F28654894E3BD457199BE38DBBDC86092693E') # Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+
+pkgver() {
+ cd usbutils
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd usbutils
+
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/hwdata
+ make
+}
+
+package() {
+ cd usbutils
+ make DESTDIR="$pkgdir" install
+ install -vDm 644 {README.md,NEWS} -t "${pkgdir}/usr/share/doc/${pkgname}/"
+}