summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-07-28 13:24:37 +0200
committerbartus2021-07-28 13:24:37 +0200
commitac8fb904f67ab25037feaf124d387de7227f7622 (patch)
treea07d451cc6a128513a7f83faf6bff66a7bbc0cdd
parent22fb9aa3171a447577776860fcf83a5a97c647f0 (diff)
downloadaur-ac8fb904f67ab25037feaf124d387de7227f7622.tar.gz
Fix build agasint gcc:11
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--demangle-fix.patch18
-rw-r--r--gcc11.patch12
4 files changed, 42 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 560503a85b8c..13cec9aedc05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -27,10 +27,13 @@ pkgbase = usd20
source = boost_python2.patch
source = blender.patch
source = std.patch
+ source = gcc11.patch
+ source = demangle-fix.patch
sha256sums = SKIP
sha256sums = 2f595ce72b9fb33e6da7db97b02be11fe6262e31b83b0e59232ee8713afed97e
sha256sums = 95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a
sha256sums = 5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5
+ sha256sums = 663352c8932a0b48230087284f4f5c540876f6a5adab3d4d1a7ee7b3a4ad6462
+ sha256sums = 99ea5fba92842d0215e5188662a066e0cc714ed4dea9c8663cb6239f6c1afbd0
pkgname = usd20
-
diff --git a/PKGBUILD b/PKGBUILD
index 40baeb965ff7..1773f718ec5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,19 +25,23 @@ url="https://graphics.pixar.com/usd/docs/index.html"
license=('Apache')
depends+=(boost{,-python2}-libs 'glew' 'openexr' 'opensubdiv')
makedepends+=(boost{,-python2} 'cmake' 'git' 'intel-tbb' 'ninja')
-conflicts=("usd")
provides=("usd=${pkgver}")
+conflicts=("usd")
source=("git+https://github.com/PixarAnimationStudios/USD.git${_fragment}"
"boost_python2.patch"
"blender.patch"
- "std.patch")
+ "std.patch"
+ "gcc11.patch"
+ "demangle-fix.patch")
sha256sums=('SKIP'
'2f595ce72b9fb33e6da7db97b02be11fe6262e31b83b0e59232ee8713afed97e'
'95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a'
- '5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5')
+ '5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5'
+ '663352c8932a0b48230087284f4f5c540876f6a5adab3d4d1a7ee7b3a4ad6462'
+ '99ea5fba92842d0215e5188662a066e0cc714ed4dea9c8663cb6239f6c1afbd0')
prepare() {
- git -C USD apply -v "${srcdir}"/{boost_python2,blender,std}.patch
+ git -C USD apply -v "${srcdir}"/{boost_python2,blender,std,demangle-fix,gcc11}.patch
}
#pkgver() {
diff --git a/demangle-fix.patch b/demangle-fix.patch
new file mode 100644
index 000000000000..a59efc6164fd
--- /dev/null
+++ b/demangle-fix.patch
@@ -0,0 +1,18 @@
+--- USD-21.02/pxr/base/arch/demangle.cpp.orig 2021-01-20 09:13:57.000000000 +0900
++++ USD-21.02/pxr/base/arch/demangle.cpp 2021-02-05 16:37:27.154126908 +0900
+@@ -36,6 +36,7 @@ using std::string;
+ #if (ARCH_COMPILER_GCC_MAJOR == 3 && ARCH_COMPILER_GCC_MINOR >= 1) || \
+ ARCH_COMPILER_GCC_MAJOR > 3 || defined(ARCH_COMPILER_CLANG)
+ #define _AT_LEAST_GCC_THREE_ONE_OR_CLANG
++#include <cxxabi.h>
+ #endif
+
+ PXR_NAMESPACE_OPEN_SCOPE
+@@ -138,7 +139,6 @@ _StripPxrInternalNamespace(string* name)
+ #endif
+
+ #if defined(_AT_LEAST_GCC_THREE_ONE_OR_CLANG)
+-#include <cxxabi.h>
+
+ /*
+ * This routine doesn't work when you get to gcc3.4.
diff --git a/gcc11.patch b/gcc11.patch
new file mode 100644
index 000000000000..57b5fb1676d6
--- /dev/null
+++ b/gcc11.patch
@@ -0,0 +1,12 @@
+diff -upr USD-21.05.orig/pxr/base/work/singularTask.h USD-21.05/pxr/base/work/singularTask.h
+--- USD-21.05.orig/pxr/base/work/singularTask.h 2021-04-13 01:09:41.000000000 +0300
++++ USD-21.05/pxr/base/work/singularTask.h 2021-06-08 23:53:13.343073026 +0300
+@@ -120,7 +120,7 @@ private:
+ // case we go again to ensure the task can do whatever it
+ // was awakened to do. Once we successfully take the count
+ // to zero, we stop.
+- size_t old = count;
++ std::size_t old = count;
+ do { _fn(); } while (
+ !count.compare_exchange_strong(old, 0));
+ });