summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-02-20 01:10:51 +0100
committerbartus2020-02-20 01:10:51 +0100
commitec5ed7e7208e753109e78ec777880aa28c5268bf (patch)
tree5d8cc0dae7dab3c13ad0968764dbe3084c9bad39
parenteaa3957565bc828dd05d8eae72dd1155515383c6 (diff)
downloadaur-ec5ed7e7208e753109e78ec777880aa28c5268bf.tar.gz
Fix boost_python27 library linking issue.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
-rw-r--r--boost_python2.patch13
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4b4d2ab0afa..6bfd92d834cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,7 @@ pkgbase = usd
source = git+https://github.com/PixarAnimationStudios/USD.git#tag=v20.02
source = boost_python2.patch
sha256sums = SKIP
- sha256sums = 7aac699cf4bca264d1cd15ed4b02c327783ac83b5cbea9bf4606e2877fa5081c
+ sha256sums = 92ff2922bf2a615e3279f1fb834dd1f0a356f843ce511efbeaf9797578409d49
pkgname = usd
diff --git a/PKGBUILD b/PKGBUILD
index 8405609e7b35..bc649c68283b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ provides=("usd=${pkgver}")
source=("git+https://github.com/PixarAnimationStudios/USD.git${_fragment}"
"boost_python2.patch")
sha256sums=('SKIP'
- '7aac699cf4bca264d1cd15ed4b02c327783ac83b5cbea9bf4606e2877fa5081c')
+ '92ff2922bf2a615e3279f1fb834dd1f0a356f843ce511efbeaf9797578409d49')
prepare() {
git -C USD apply -v ${srcdir}/boost_python2.patch
@@ -29,12 +29,19 @@ prepare() {
build() {
_CMAKE_FLAGS+=(
- -DPXR_BUILD_TESTS=OFF
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr
+ -DPXR_BUILD_TESTS:BOOL=OFF
+# -DPXR_ENABLE_PYTHON_SUPPORT:BOOL=OFF
+ -DPXR_PYTHON_SHEBANG:STRING=python2
)
cmake -S USD -B build -G Ninja "${_CMAKE_FLAGS[@]}"
ninja -C build $([ -v MAKEFLAGS ] || echo -j1)
}
+#check() {
+# ninja -C build test
+#}
+
package() {
DESTDIR="$pkgdir" ninja -C build install
}
diff --git a/boost_python2.patch b/boost_python2.patch
index 4f68dd6fa529..ad9fdcafed04 100644
--- a/boost_python2.patch
+++ b/boost_python2.patch
@@ -1,8 +1,13 @@
diff --git a/cmake/defaults/Packages.cmake b/cmake/defaults/Packages.cmake
-index 7968add25..55f336da8 100644
+index 7968add25..86619cb2e 100644
--- a/cmake/defaults/Packages.cmake
+++ b/cmake/defaults/Packages.cmake
-@@ -46,7 +46,7 @@ if(PXR_ENABLE_PYTHON_SUPPORT)
+@@ -43,12 +43,16 @@ if(PXR_ENABLE_PYTHON_SUPPORT)
+ find_package(PythonLibs 2.7 REQUIRED)
+
+ # --Boost
++ # replace 'python' with 'python27' as boost>=1.67 require python version suffix
++ # https://cmake.org/cmake/help/v3.15/module/FindBoost.html
find_package(Boost
COMPONENTS
program_options
@@ -10,4 +15,8 @@ index 7968add25..55f336da8 100644
+ python27
REQUIRED
)
++ # fix rest of code expecting 'Boost_PYTHON_LIBRAR'
++ set(Boost_PYTHON_LIBRARY "${Boost_PYTHON27_LIBRARY}")
+ # --Jinja2
+ find_package(Jinja2)