summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-03-03 22:19:48 +0100
committerbartus2020-03-03 22:22:24 +0100
commit2fe3923cfaffe20c0c0fb8649e8a6c81ae88e919 (patch)
tree13954a240a57d442d81a28e4b711a0dfc3984861
parent2289d75548b77a37d6268801a53b0f8ffcf52b10 (diff)
downloadaur-2fe3923cfaffe20c0c0fb8649e8a6c81ae88e919.tar.gz
Fix python install path.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--boost_python2.patch99
3 files changed, 104 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abcdc9fcbd85..2e6b231166b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = usd
pkgdesc = 3D VFX pipeline interchange file format.
pkgver = 19.11
- pkgrel = 1
+ pkgrel = 2
url = https://www.openusd.org
arch = x86_64
license = Apache
@@ -16,15 +16,15 @@ pkgbase = usd
depends = glew
depends = openexr
depends = opensubdiv
- depends = pyside2
depends = python2
depends = python2-opengl
+ depends = python2-pyside
provides = usd=19.11
source = git+https://github.com/PixarAnimationStudios/USD.git#tag=v19.11
source = boost_python2.patch
source = blender.patch
sha256sums = SKIP
- sha256sums = 92ff2922bf2a615e3279f1fb834dd1f0a356f843ce511efbeaf9797578409d49
+ sha256sums = 39b52f008bcebbd2bb57e165e85622b3452de9f10342b82f38e305d934486f46
sha256sums = a4b92e59eb6330109f65d1b168ad0c4b1292c5317f579dcbf0594df22ffbc587
pkgname = usd
diff --git a/PKGBUILD b/PKGBUILD
index 04855dfeef1a..aaae0dc296d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,19 @@ _fragment="#tag=$_ver"
pkgname=usd
pkgver=${_ver#v}
-pkgrel=1
+pkgrel=2
pkgdesc="3D VFX pipeline interchange file format."
arch=('x86_64')
url="https://www.openusd.org"
license=('Apache')
-eval depends=('boost-libs' 'glew' 'openexr' 'opensubdiv' 'pyside2' "python2{,-opengl}")
+eval depends=('boost-libs' 'glew' 'openexr' 'opensubdiv' "python2{,-opengl,-pyside}")
eval makedepends=('boost' 'cmake' 'git' 'intel-tbb' 'ninja' "python2-{jinja,pyside-tools}")
provides=("usd=${pkgver}")
source=("git+https://github.com/PixarAnimationStudios/USD.git${_fragment}"
"boost_python2.patch"
"blender.patch")
sha256sums=('SKIP'
- '92ff2922bf2a615e3279f1fb834dd1f0a356f843ce511efbeaf9797578409d49'
+ '39b52f008bcebbd2bb57e165e85622b3452de9f10342b82f38e305d934486f46'
'a4b92e59eb6330109f65d1b168ad0c4b1292c5317f579dcbf0594df22ffbc587')
prepare() {
diff --git a/boost_python2.patch b/boost_python2.patch
index ad9fdcafed04..b35028a961f7 100644
--- a/boost_python2.patch
+++ b/boost_python2.patch
@@ -1,5 +1,5 @@
diff --git a/cmake/defaults/Packages.cmake b/cmake/defaults/Packages.cmake
-index 7968add25..86619cb2e 100644
+index 9be215b36..031c64ab0 100644
--- a/cmake/defaults/Packages.cmake
+++ b/cmake/defaults/Packages.cmake
@@ -43,12 +43,16 @@ if(PXR_ENABLE_PYTHON_SUPPORT)
@@ -20,3 +20,100 @@ index 7968add25..86619cb2e 100644
# --Jinja2
find_package(Jinja2)
+diff --git a/cmake/macros/Private.cmake b/cmake/macros/Private.cmake
+index 32274b3f4..d6ee46b51 100644
+--- a/cmake/macros/Private.cmake
++++ b/cmake/macros/Private.cmake
+@@ -120,7 +120,7 @@ function(_install_python LIBRARY_NAME)
+ ${ARGN}
+ )
+
+- set(libPythonPrefix lib/python)
++ set(libPythonPrefix lib/python2.7/site-packages)
+ _get_python_module_name(${LIBRARY_NAME} LIBRARY_INSTALLNAME)
+
+ set(files_copied "")
+@@ -268,7 +268,7 @@ function(_install_pyside_ui_files LIBRARY_NAME)
+ FOLDER "${folder}"
+ )
+
+- set(libPythonPrefix lib/python)
++ set(libPythonPrefix lib/python2.7/site-packages)
+ _get_python_module_name(${LIBRARY_NAME} LIBRARY_INSTALLNAME)
+
+ install(
+@@ -947,7 +947,7 @@ function(_pxr_python_module NAME)
+ # 'from pxr import X'. Additionally, python libraries always install
+ # into the default lib install, not into the third_party subdirectory
+ # or similar.
+- set(libInstallPrefix "lib/python/pxr/${pyModuleName}")
++ set(libInstallPrefix "lib/python2.7/site-packages/pxr/${pyModuleName}")
+
+ # Python modules need to be able to access their corresponding
+ # wrapped library and the install lib directory.
+diff --git a/cmake/macros/Public.cmake b/cmake/macros/Public.cmake
+index ed9ae9a31..f9c023f44 100644
+--- a/cmake/macros/Public.cmake
++++ b/cmake/macros/Public.cmake
+@@ -350,7 +350,7 @@ function(pxr_setup_python)
+ string(REPLACE ";" ", " pyModulesStr "${converted}")
+
+ # Install a pxr __init__.py with an appropriate __all__
+- _get_install_dir(lib/python/pxr installPrefix)
++ _get_install_dir(lib/python2.7/site-packages/pxr installPrefix)
+
+ file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/generated_modules_init.py"
+ "__all__ = [${pyModulesStr}]\n")
+@@ -391,7 +391,7 @@ function (pxr_create_test_module MODULE_NAME)
+ RENAME
+ __init__.py
+ DESTINATION
+- tests/${tm_INSTALL_PREFIX}/lib/python/${MODULE_NAME}
++ tests/${tm_INSTALL_PREFIX}/lib/python2.7/site-packages/pxr/${MODULE_NAME}
+ )
+ endif()
+ if (EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/${plugInfoFile}")
+@@ -401,7 +401,7 @@ function (pxr_create_test_module MODULE_NAME)
+ RENAME
+ plugInfo.json
+ DESTINATION
+- tests/${tm_INSTALL_PREFIX}/lib/python/${MODULE_NAME}
++ tests/${tm_INSTALL_PREFIX}/lib/python2.7/site-packages/pxr/${MODULE_NAME}
+ )
+ endif()
+ endfunction() # pxr_create_test_module
+@@ -704,7 +704,7 @@ function(pxr_register_test TEST_NAME)
+ # Ensure that Python imports the Python files built by this build.
+ # On Windows convert backslash to slash and don't change semicolons
+ # to colons.
+- set(_testPythonPath "${CMAKE_INSTALL_PREFIX}/lib/python;$ENV{PYTHONPATH}")
++ set(_testPythonPath "${CMAKE_INSTALL_PREFIX}/lib/python2.7/site-packages/pxr;$ENV{PYTHONPATH}")
+ if(WIN32)
+ string(REGEX REPLACE "\\\\" "/" _testPythonPath "${_testPythonPath}")
+ else()
+diff --git a/pxr/base/lib/plug/testPlug.py b/pxr/base/lib/plug/testPlug.py
+index 377e66632..776a1317a 100644
+--- a/pxr/base/lib/plug/testPlug.py
++++ b/pxr/base/lib/plug/testPlug.py
+@@ -32,7 +32,7 @@ from pxr import Plug, Tf, Gf
+ # Test plugins are installed relative to this script
+ testRoot = os.path.join(os.path.dirname(__file__), 'PlugPlugins')
+ testPluginsDso = testRoot + '/lib'
+-testPluginsPython = testRoot + '/lib/python'
++testPluginsPython = testRoot + '/lib/python2.7/site-packages/pxr'
+ testPluginsDsoSearch = testPluginsDso + '/*/Resources/'
+ testPluginsPythonSearch = testPluginsPython + '/**/'
+
+diff --git a/pxr/usdImaging/lib/usdviewq/CMakeLists.txt b/pxr/usdImaging/lib/usdviewq/CMakeLists.txt
+index 66c5b2091..91c878bf3 100644
+--- a/pxr/usdImaging/lib/usdviewq/CMakeLists.txt
++++ b/pxr/usdImaging/lib/usdviewq/CMakeLists.txt
+@@ -80,7 +80,7 @@ pxr_library(usdviewq
+
+ install(DIRECTORY
+ icons
+- DESTINATION lib/python/pxr/Usdviewq
++ DESTINATION lib/python2.7/site-packages/pxr/Usdviewq
+ )
+
+ pxr_test_scripts(