summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-01-07 12:46:17 +0100
committerbartus2021-01-07 12:46:17 +0100
commitf01066cdb1d2b2658b43d8b9f6e79b938bd93a90 (patch)
tree088089eec12abc9c2f0ee9cc0df6cfd12929ee71
parent791f46ea4ea6e1c03c734538e4648afe91503ab2 (diff)
downloadaur-f01066cdb1d2b2658b43d8b9f6e79b938bd93a90.tar.gz
Fix missing std lib header
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--std.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0be9820a1b15..5de591978918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,9 +26,11 @@ pkgbase = usd-qfix
source = git+https://github.com/PixarAnimationStudios/USD.git#tag=v20.05
source = boost_python2.patch
source = blender.patch
+ source = std.patch
sha256sums = SKIP
sha256sums = 2f595ce72b9fb33e6da7db97b02be11fe6262e31b83b0e59232ee8713afed97e
sha256sums = 95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a
+ sha256sums = 5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5
pkgname = usd-qfix
diff --git a/PKGBUILD b/PKGBUILD
index 3344b8d44b21..d6f751ab6c26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,13 +29,15 @@ provides=("usd=${pkgver}")
conflicts=("usd")
source=("git+https://github.com/PixarAnimationStudios/USD.git${_fragment}"
"boost_python2.patch"
- "blender.patch")
+ "blender.patch"
+ "std.patch")
sha256sums=('SKIP'
'2f595ce72b9fb33e6da7db97b02be11fe6262e31b83b0e59232ee8713afed97e'
- '95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a')
+ '95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a'
+ '5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5')
prepare() {
- git -C USD apply -v "${srcdir}"/{boost_python2,blender}.patch
+ git -C USD apply -v "${srcdir}"/{boost_python2,blender,std}.patch
}
#pkgver() {
diff --git a/std.patch b/std.patch
new file mode 100644
index 000000000000..c10ce34924c1
--- /dev/null
+++ b/std.patch
@@ -0,0 +1,13 @@
+diff --git a/pxr/usd/ar/packageUtils.cpp b/pxr/usd/ar/packageUtils.cpp
+index d497587b3..ed3df295f 100644
+--- a/pxr/usd/ar/packageUtils.cpp
++++ b/pxr/usd/ar/packageUtils.cpp
+@@ -29,6 +29,8 @@
+ #include "pxr/base/tf/pathUtils.h"
+ #include "pxr/base/tf/stringUtils.h"
+
++#include <algorithm>
++
+ PXR_NAMESPACE_OPEN_SCOPE
+
+ namespace