summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlanthora2023-03-30 15:34:01 +0000
committerlanthora2023-03-30 15:34:01 +0000
commit1f73ec87d77b497c144e03b9909909345a9deca5 (patch)
tree0e05d2e52c361c26ab909497e3bc2e4e27d54e5c
parent15afd384112d96845e9313931b88061bedc75dbe (diff)
downloadaur-1f73ec87d77b497c144e03b9909909345a9deca5.tar.gz
fix WITH_OPENSSL
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--usockets-0.8.5-Makefile.patch74
3 files changed, 39 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffcac82d03d0..a006c494e06e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = usockets
pkgdesc = Miniscule cross-platform eventing, networking & crypto for async applications
pkgver = 0.8.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/uNetworking/uSockets
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 76a30291bbda..b51aaadaca4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=usockets
pkgname=usockets
pkgver=0.8.5
-pkgrel=1
+pkgrel=2
pkgdesc="Miniscule cross-platform eventing, networking & crypto for async applications"
url="https://github.com/uNetworking/uSockets"
license=('Apache')
diff --git a/usockets-0.8.5-Makefile.patch b/usockets-0.8.5-Makefile.patch
index a19e6154bd1d..7df3e52c2442 100644
--- a/usockets-0.8.5-Makefile.patch
+++ b/usockets-0.8.5-Makefile.patch
@@ -1,30 +1,14 @@
diff --git a/Makefile b/Makefile
-index f6e2c6b..59c6e1a 100644
+index f6e2c6b..4525b38 100644
--- a/Makefile
+++ b/Makefile
-@@ -3,96 +3,63 @@ ifneq ($(WITH_LTO),0)
+@@ -3,96 +3,61 @@ ifneq ($(WITH_LTO),0)
override CFLAGS += -flto
endif
-+DESTDIR ?=
-+
-+prefix ?= /usr
-+exec_prefix ?= $(prefix)
-+LIB ?= lib
-+libdir ?= $(exec_prefix)/$(LIB)
-+includedir ?= $(exec_prefix)/include
-+
-+PKG_CONFIG ?= pkg-config
-+
-+VERSION ?= 0.0
-+LIBTARGET = libusockets.so.$(VERSION)
-+
-+REQUIRES =
-+COMMON_FLAGS = -Isrc
-+
- # WITH_BORINGSSL=1 enables BoringSSL support, linked statically (preferred over OpenSSL)
- # You need to call "make boringssl" before
- ifeq ($(WITH_BORINGSSL),1)
+-# WITH_BORINGSSL=1 enables BoringSSL support, linked statically (preferred over OpenSSL)
+-# You need to call "make boringssl" before
+-ifeq ($(WITH_BORINGSSL),1)
- override CFLAGS += -Iboringssl/include -pthread -DLIBUS_USE_OPENSSL
- override LDFLAGS += -pthread boringssl/build/ssl/libssl.a boringssl/build/crypto/libcrypto.a -lstdc++
-else
@@ -44,18 +28,19 @@ index f6e2c6b..59c6e1a 100644
- override CFLAGS += -DLIBUS_NO_SSL
- endif
- endif
-+COMMON_FLAGS += -DLIBUS_USE_OPENSSL
-+LDFLAGS += -lstdc++
-+REQUIRES += libssl libcrypto
- endif
+-endif
++DESTDIR ?=
- # WITH_LIBUV=1 builds with libuv as event-loop
- ifeq ($(WITH_LIBUV),1)
+-# WITH_LIBUV=1 builds with libuv as event-loop
+-ifeq ($(WITH_LIBUV),1)
- override CFLAGS += -DLIBUS_USE_LIBUV
- override LDFLAGS += -luv
-+COMMON_FLAGS += -DLIBUS_USE_LIBUV
-+REQUIRES += libuv
- endif
+-endif
++prefix ?= /usr
++exec_prefix ?= $(prefix)
++LIB ?= lib
++libdir ?= $(exec_prefix)/$(LIB)
++includedir ?= $(exec_prefix)/include
-# WITH_ASIO builds with boot asio event-loop
-ifeq ($(WITH_ASIO),1)
@@ -63,20 +48,28 @@ index f6e2c6b..59c6e1a 100644
- override LDFLAGS += -lstdc++ -lpthread
- override CXXFLAGS += -pthread -DLIBUS_USE_ASIO
-endif
--
++PKG_CONFIG ?= pkg-config
+
-# WITH_GCD=1 builds with libdispatch as event-loop
-ifeq ($(WITH_GCD),1)
- override CFLAGS += -DLIBUS_USE_GCD
- override LDFLAGS += -framework CoreFoundation
-endif
--
++VERSION ?= 0.0
++LIBTARGET = libusockets.so.$(VERSION)
++
++REQUIRES =
++COMMON_FLAGS = -Isrc
+
-# WITH_ASAN builds with sanitizers
-ifeq ($(WITH_ASAN),1)
- override CFLAGS += -fsanitize=address -g
- override LDFLAGS += -fsanitize=address
--endif
-+CFLAGS += -std=c11 $(COMMON_FLAGS)
-+CXXFLAGS += -std=c++17 $(COMMON_FLAGS)
++ifeq ($(WITH_OPENSSL),1)
++COMMON_FLAGS += -DLIBUS_USE_OPENSSL
++LDFLAGS += -lstdc++
++REQUIRES += libssl libcrypto
+ endif
-ifeq ($(WITH_QUIC),1)
- override CFLAGS += -DLIBUS_USE_QUIC -pthread -std=c11 -Isrc -Ilsquic/include
@@ -84,9 +77,16 @@ index f6e2c6b..59c6e1a 100644
-else
- override CFLAGS += -std=c11 -Isrc
- override LDFLAGS += uSockets.a
--endif
--
++# WITH_LIBUV=1 builds with libuv as event-loop
++ifeq ($(WITH_LIBUV),1)
++COMMON_FLAGS += -DLIBUS_USE_LIBUV
++REQUIRES += libuv
+ endif
+
-# By default we build the uSockets.a static library
++CFLAGS += -std=c11 $(COMMON_FLAGS)
++CXXFLAGS += -std=c++17 $(COMMON_FLAGS)
++
default:
- rm -f *.o
- $(CC) $(CFLAGS) -O3 -c src/*.c src/eventing/*.c src/crypto/*.c