summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlanthora2023-03-30 16:03:58 +0000
committerlanthora2023-03-30 16:03:58 +0000
commit5d3aa64f93d7b09299db9b585b4664f8144eed8f (patch)
tree2eac25b157052284b37b967726ffdb1bbbdb1396
parent1f73ec87d77b497c144e03b9909909345a9deca5 (diff)
downloadaur-5d3aa64f93d7b09299db9b585b4664f8144eed8f.tar.gz
fix CFLAGS
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--usockets-0.8.5-Makefile.patch13
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a006c494e06e..8c394c41bbcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = usockets
pkgdesc = Miniscule cross-platform eventing, networking & crypto for async applications
pkgver = 0.8.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/uNetworking/uSockets
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index b51aaadaca4b..d74810c0bddc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=usockets
pkgname=usockets
pkgver=0.8.5
-pkgrel=2
+pkgrel=3
pkgdesc="Miniscule cross-platform eventing, networking & crypto for async applications"
url="https://github.com/uNetworking/uSockets"
license=('Apache')
diff --git a/usockets-0.8.5-Makefile.patch b/usockets-0.8.5-Makefile.patch
index 7df3e52c2442..071deb36b2ce 100644
--- a/usockets-0.8.5-Makefile.patch
+++ b/usockets-0.8.5-Makefile.patch
@@ -1,9 +1,12 @@
diff --git a/Makefile b/Makefile
-index f6e2c6b..4525b38 100644
+index f6e2c6b..71d4d05 100644
--- a/Makefile
+++ b/Makefile
-@@ -3,96 +3,61 @@ ifneq ($(WITH_LTO),0)
- override CFLAGS += -flto
+@@ -1,98 +1,63 @@
+ # By default we use LTO, but Windows does not support it
+ ifneq ($(WITH_LTO),0)
+- override CFLAGS += -flto
++CFLAGS += -flto
endif
-# WITH_BORINGSSL=1 enables BoringSSL support, linked statically (preferred over OpenSSL)
@@ -94,12 +97,12 @@ index f6e2c6b..4525b38 100644
-ifeq ($(WITH_ASIO),1)
- $(CXX) $(CXXFLAGS) -Isrc -std=c++14 -flto -O3 -c src/eventing/asio.cpp
-endif
-+ $(CC) $(CFLAGS) -fPIC -c -I src src/*.c src/eventing/*.c src/crypto/*.c
++ $(CC) $(CFLAGS) -fPIC -c src/*.c src/eventing/*.c src/crypto/*.c
-# For now we do rely on C++17 for OpenSSL support but we will be porting this work to C11
ifeq ($(WITH_OPENSSL),1)
- $(CXX) $(CXXFLAGS) -std=c++17 -flto -O3 -c src/crypto/*.cpp
-+ $(CXX) $(CXXFLAGS) -fPIC -c -I src src/crypto/*.cpp
++ $(CXX) $(CXXFLAGS) -fPIC -c src/crypto/*.cpp
endif
-ifeq ($(WITH_BORINGSSL),1)
- $(CXX) $(CXXFLAGS) -std=c++17 -flto -O3 -c src/crypto/*.cpp