summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2024-02-13 10:46:50 +0000
committerScore_Under2024-02-13 10:46:50 +0000
commitdf28c01afa18c7409ff9cad50ffc32b2c5df23a8 (patch)
tree94f15eed63c824ad4c2bc2da27f491666f0b6a21
parent313717f26e56aff0938f06e8a574ce4f00b42d41 (diff)
downloadaur-df28c01afa18c7409ff9cad50ffc32b2c5df23a8.tar.gz
Use srcdir/source array for source patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3eb37297c412..515a5c9c0357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = usockets
license = Apache
depends = openssl
source = https://github.com/uNetworking/uSockets/archive/refs/tags/v0.8.5.tar.gz
- md5sums = e07e6a53cba781455fcf3cf71e9760c3
+ source = usockets-0.8.5-Makefile.patch
+ sha256sums = c52c98b7ff2c24534c17ad97d5fea8ca0cb7ff38cc933b8d08bac6e498a2ea6b
+ sha256sums = efeac07919bc804d24b10eceaa2145e8cfa5f2e95edec9e47a94bba5a825b55b
pkgname = usockets
diff --git a/PKGBUILD b/PKGBUILD
index 90894c0e6d92..65da818d62bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,23 +9,25 @@ pkgdesc="Miniscule cross-platform eventing, networking & crypto for async applic
url="https://github.com/uNetworking/uSockets"
license=('Apache')
arch=('x86_64')
-source=( "https://github.com/uNetworking/uSockets/archive/refs/tags/v${pkgver}.tar.gz" )
-md5sums=('e07e6a53cba781455fcf3cf71e9760c3')
+source=("https://github.com/uNetworking/uSockets/archive/refs/tags/v${pkgver}.tar.gz"
+ "usockets-$pkgver-Makefile.patch")
+sha256sums=('c52c98b7ff2c24534c17ad97d5fea8ca0cb7ff38cc933b8d08bac6e498a2ea6b'
+ 'efeac07919bc804d24b10eceaa2145e8cfa5f2e95edec9e47a94bba5a825b55b')
depends=( openssl )
prepare() {
cd "uSockets-$pkgver"
- patch < ../../usockets-$pkgver-Makefile.patch
+ patch < "$srcdir/usockets-$pkgver-Makefile.patch"
}
build() {
cd "uSockets-$pkgver"
- make VERSION=$pkgver WITH_OPENSSL=1 default
+ make VERSION="$pkgver" WITH_OPENSSL=1 default
}
package() {
cd "uSockets-$pkgver"
- make VERSION=$pkgver DESTDIR="$pkgdir/" install
+ make VERSION="$pkgver" DESTDIR="$pkgdir/" install
}
#vim: syntax=sh