summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Wegener2018-02-25 16:10:19 +1100
committerChristoph Wegener2018-02-25 16:10:19 +1100
commitd32815153ae8f454666ff9f337e51f07c8c2718b (patch)
tree3fcd2958ec12ac8774c0548ef04168aa3eb6aa35
parentcbd478c1d1f0a6fdd93d9d0790dbf5cf4821f155 (diff)
downloadaur-d32815153ae8f454666ff9f337e51f07c8c2718b.tar.gz
Update to version 0.6.0
* Removed Avatica driver (does not compile) * Changed URL from github.com/knq to github.com/xo
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 290f94b59b36..f983eddcfc82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,16 @@
pkgname='usql'
_gitname='usql'
-pkgver='0.5.0'
+pkgver='0.6.0'
pkgrel='1'
pkgdesc='usql is a universal command-line interface for SQL databases'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-url='https://github.com/knq/usql'
+url='https://github.com/xo/usql'
license=('MIT')
depends=('go')
makedepends=('go' 'git')
provides=('usql')
-#backup=('etc/influxdb/influxdb.conf')
-#install='influxdb.install'
-source=("git+https://github.com/knq/usql#tag=v$pkgver")
+source=("git+https://github.com/xo/usql#tag=v$pkgver")
md5sums=('SKIP')
build()
{
@@ -23,22 +21,23 @@ build()
go get -u github.com/kardianos/govendor
- mkdir -p "$GOPATH/src/github.com/knq"
- mv -f "$srcdir/usql" "$GOPATH/src/github.com/knq/"
+ mkdir -p "$GOPATH/src/github.com/xo"
+ mv -f "$srcdir/usql" "$GOPATH/src/github.com/xo/"
- cd "$GOPATH/src/github.com/knq/usql"
+ cd "$GOPATH/src/github.com/xo/usql"
echo "Building usql version=$pkgver"
- #go install -ldflags="-X main.version=$version -X main.commit=$revision -X main.branch=master" ./...
TAGS="most fts5 vtable json1"
- TAGS="$TAGS no_adodb"
+ # Remove ADODB (unavailable on linux)
+ # Temporarily remove Avatica (does not compile successfully)
+ TAGS="$TAGS no_adodb no_avatica"
govendor init
govendor fetch ./...
- govendor remove github.com/knq/usql/internal
+ govendor remove github.com/xo/usql/internal
go install -tags "$TAGS" \
- -ldflags="-X github.com/knq/usql/text.CommandName=$pkgname -X github.com/knq/usql/text.CommandVersion=$pkgver"
+ -ldflags="-X github.com/xo/usql/text.CommandName=$pkgname -X github.com/xo/usql/text.CommandVersion=$pkgver"
}
@@ -47,7 +46,7 @@ package()
cd $GOBIN
install -Dsm755 usql "$pkgdir/usr/bin/usql"
- cd "$GOPATH/src/github.com/knq/usql"
+ cd "$GOPATH/src/github.com/xo/usql"
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/usql/README.md"
install -Dm644 "contrib/usqlpass" "${pkgdir}/usr/share/doc/usql/usqlpass"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/usql/LICENSE"