summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Devaev2024-04-07 18:12:36 +0300
committerMaxim Devaev2024-04-07 18:12:36 +0300
commit33c1fd94bf93011906762944c40ca5c301d9c86d (patch)
treec74d94744fc83bd6a81764845fe387b55de82c0f
parentd5a9d668d3008189d1917a85ca117c7e6deb1473 (diff)
downloadaur-ustreamer.tar.gz
update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f16e99ba070..60cf1e376477 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ustreamer
pkgdesc = Lightweight and fast MJPEG-HTTP streamer
- pkgver = 6.4
+ pkgver = 6.11
pkgrel = 1
url = https://github.com/pikvm/ustreamer
arch = i686
@@ -13,6 +13,9 @@ pkgbase = ustreamer
makedepends = make
makedepends = systemd
makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-wheel
makedepends = janus-gateway
makedepends = alsa-lib
makedepends = opus
@@ -25,7 +28,7 @@ pkgbase = ustreamer
depends = janus-gateway
depends = alsa-lib
depends = opus
- source = ustreamer::git+https://github.com/pikvm/ustreamer#commit=v6.4
+ source = ustreamer::git+https://github.com/pikvm/ustreamer#commit=v6.11
md5sums = SKIP
pkgname = ustreamer
diff --git a/PKGBUILD b/PKGBUILD
index fe31cb0d86df..c19084395c43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ustreamer
-pkgver=6.4
+pkgver=6.11
pkgrel=1
pkgdesc="Lightweight and fast MJPEG-HTTP streamer"
url="https://github.com/pikvm/ustreamer"
@@ -19,7 +19,7 @@ _options="WITH_GPIO=1 WITH_SYSTEMD=1"
if [ -e /usr/bin/python3 ]; then
_options="$_options WITH_PYTHON=1"
depends+=(python)
- makedepends+=(python-setuptools)
+ makedepends+=(python-setuptools python-pip python-build python-wheel)
fi
if [ -e /usr/include/janus/plugins/plugin.h ];then
depends+=(janus-gateway alsa-lib opus)
@@ -28,12 +28,6 @@ if [ -e /usr/include/janus/plugins/plugin.h ];then
fi
-# LD does not link mmal with this option
-# This DOESN'T affect setup.py
-LDFLAGS="${LDFLAGS//--as-needed/}"
-export LDFLAGS="${LDFLAGS//,,/,}"
-
-
build() {
cd "$srcdir"
rm -rf $pkgname-build