summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevaev Maxim2020-12-07 13:36:08 +0300
committerDevaev Maxim2020-12-07 13:36:08 +0300
commit66636fcd1388537d8180e3f9e8fe1ed260d27388 (patch)
treec6d92764317722681fbf0b94ec5682f5883c4de7
parentbef8329f51ecec9ccdce7f8c55dda0a6611477e3 (diff)
downloadaur-66636fcd1388537d8180e3f9e8fe1ed260d27388.tar.gz
2.2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5a3dffdd97f..e96a802fc825 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ustreamer
pkgdesc = Lightweight and fast MJPG-HTTP streamer
- pkgver = 1.25
+ pkgver = 2.2
pkgrel = 1
url = https://github.com/pikvm/ustreamer
arch = i686
@@ -15,7 +15,8 @@ pkgbase = ustreamer
depends = libevent
depends = libutil-linux
depends = libbsd
- source = ustreamer::git+https://github.com/pikvm/ustreamer#commit=v1.25
+ depends = libgpiod
+ source = ustreamer::git+https://github.com/pikvm/ustreamer#commit=v2.2
md5sums = SKIP
pkgname = ustreamer
diff --git a/PKGBUILD b/PKGBUILD
index 86949c1dbde3..8955ffc77db8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=ustreamer
-pkgver=1.25
+pkgver=2.2
pkgrel=1
pkgdesc="Lightweight and fast MJPG-HTTP streamer"
url="https://github.com/pikvm/ustreamer"
license=(GPL)
arch=(i686 x86_64 armv6h armv7h aarch64)
-depends=(libjpeg libevent libutil-linux libbsd)
+depends=(libjpeg libevent libutil-linux libbsd libgpiod)
# optional: raspberrypi-firmware for OMX encoder
-# optional: wiringpi for GPIO support
makedepends=(gcc make)
source=(${pkgname}::"git+https://github.com/pikvm/ustreamer#commit=v${pkgver}")
md5sums=(SKIP)
@@ -23,9 +22,8 @@ build() {
cp -r $pkgname $pkgname-build
cd $pkgname-build
- local _options=""
+ local _options="WITH_GPIO=1"
[ -e /opt/vc/include/IL/OMX_Core.h ] && _options="$_options WITH_OMX=1"
- [ -e /usr/include/wiringPi.h ] && _options="$_options WITH_GPIO=1"
make $_options CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" $MAKEFLAGS
}