summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevaev Maxim2019-05-26 05:58:22 +0300
committerDevaev Maxim2019-05-26 05:58:22 +0300
commit9fd5c9d4781efbcd79178d97f053de96ce22a470 (patch)
tree0577893c220f24ff5147b7e412a88cfc9e712456
parent188ea399759d3a1acce86d86f02277ccf1e60672 (diff)
downloadaur-9fd5c9d4781efbcd79178d97f053de96ce22a470.tar.gz
Update to 0.76-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08ed7ba5ca6f..ca60db5fdc69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ustreamer
pkgdesc = Lightweight and fast MJPG-HTTP streamer
- pkgver = 0.75
+ pkgver = 0.76
pkgrel = 1
url = https://github.com/pi-kvm/ustreamer
arch = i686
@@ -13,7 +13,7 @@ pkgbase = ustreamer
depends = libjpeg
depends = libevent
depends = libutil-linux
- source = https://github.com/pi-kvm/ustreamer/archive/v0.75.tar.gz
+ source = ustreamer::git+https://github.com/pi-kvm/ustreamer#commit=0.76
md5sums = SKIP
pkgname = ustreamer
diff --git a/PKGBUILD b/PKGBUILD
index 0630c2c7db49..85d0ae7abfb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ustreamer
-pkgver=0.75
+pkgver=0.76
pkgrel=1
pkgdesc="Lightweight and fast MJPG-HTTP streamer"
url="https://github.com/pi-kvm/ustreamer"
@@ -12,19 +12,23 @@ arch=(i686 x86_64 armv6h armv7h)
depends=(libjpeg libevent libutil-linux)
# optional: raspberrypi-firmware for OMX JPEG encoder
makedepends=(gcc make)
-source=("$url/archive/v$pkgver.tar.gz")
+source=(${pkgname}::"git+https://github.com/pi-kvm/ustreamer#commit=${pkgver}")
md5sums=(SKIP)
build() {
- cd $srcdir
+ cd "$srcdir"
rm -rf $pkgname-build
- cp -r $pkgname-$pkgver $pkgname-build
+ cp -r $pkgname $pkgname-build
cd $pkgname-build
- make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" $MAKEFLAGS
+
+ local _options=""
+ [ -d /opt/vc/include ] && _options="$_options WITH_OMX_ENCODER=1"
+
+ make $_options CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" $MAKEFLAGS
}
package() {
- cd $srcdir/$pkgname-build
+ cd "$srcdir/$pkgname-build"
make DESTDIR="$pkgdir" PREFIX=/usr install
}