summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 14:44:07 +0200
committeraksr2015-06-28 14:44:07 +0200
commit8caead58ec207e6e87712712a5572579b0d6b1b5 (patch)
tree9b0db8963bb423cc4bd223e3f1e071acc18386b3
downloadaur-8caead58ec207e6e87712712a5572579b0d6b1b5.tar.gz
Start.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e91d82c46416
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = utmp-git
+ pkgdesc = A small program which updates the utmp record of the current tty.
+ pkgver = 0.r6.f9178df
+ pkgrel = 1
+ url = http://git.suckless.org/utmp/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ conflicts = utmp
+ source = utmp-git::git+git://git.suckless.org/utmp
+ md5sums = SKIP
+
+pkgname = utmp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b4d43dd1da5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=utmp-git
+pkgver=0.r6.f9178df
+pkgrel=1
+epoch=
+pkgdesc="A small program which updates the utmp record of the current tty."
+arch=('i686' 'x86_64')
+url="http://git.suckless.org/utmp/"
+license=('MIT')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('utmp')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+git://git.suckless.org/utmp")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure
+ sed -i 's/\/usr\/local/\/usr/' config.mk
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+