summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredchenjs2019-07-01 12:49:28 +0800
committerredchenjs2019-07-01 12:49:28 +0800
commitad4e57b29d7eea77738c1d3d91e6ab626603eacc (patch)
treebe84d2f6c457042f0f111b4187997a08d8a6898d
downloadaur-ad4e57b29d7eea77738c1d3d91e6ab626603eacc.tar.gz
init commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8f0a651bc7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = utools
+ pkgdesc = uTools-你的生产力工具集
+ pkgver = 0.7.0_beta
+ pkgrel = 1
+ url = https://u.tools/
+ arch = x86_64
+ license = custom
+ depends = gconf
+ depends = libnotify
+ depends = libappindicator-gtk2
+ depends = libappindicator-gtk3
+ depends = libxtst
+ depends = nss
+ depends = libxss
+ source = https://resource.u-tools.cn/version/utools_0.7.0-beta_amd64.deb
+ md5sums = 64a639421f36849a549f0b290a8c81f8
+
+pkgname = utools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a7b8f64b98ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0547c7da163f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jack Chen <redchenjs@live.com>
+
+pkgname=utools
+pkgver=0.7.0_beta
+pkgrel=1
+pkgdesc="uTools-你的生产力工具集"
+arch=('x86_64')
+url="https://u.tools/"
+license=('custom')
+depends=(
+ 'gconf'
+ 'libnotify'
+ 'libappindicator-gtk2'
+ 'libappindicator-gtk3'
+ 'libxtst'
+ 'nss'
+ 'libxss'
+)
+source=(
+ 'https://resource.u-tools.cn/version/utools_0.7.0-beta_amd64.deb'
+)
+md5sums=(
+ '64a639421f36849a549f0b290a8c81f8'
+)
+
+package() {
+ tar -xf "${srcdir}"/data.tar.xz -C "${pkgdir}"/
+}