summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-08-18 14:10:41 +0300
committervlad2015-08-18 14:10:41 +0300
commit41054288c3d69332efac2a3b540284ac0e4430d9 (patch)
tree350b09cf27ae59996f2961c0e45fe971eaf2c7cf
parent11db036880b69a40445b0d47b2670a3dd0249b01 (diff)
downloadaur-41054288c3d69332efac2a3b540284ac0e4430d9.tar.gz
format
-rw-r--r--PKGBUILD36
1 files changed, 13 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2bc8e6cee37..cf27b452ebcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,49 +6,39 @@ _pkgname=utox
pkgname=utox-git
pkgver=0.3.2.r41.gd16f539
pkgrel=1
-
pkgdesc='Lightweight Tox client'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url='https://github.com/notsecure/uTox'
license=('GPL3')
-
-depends=(
- 'desktop-file-utils'
- 'fontconfig'
- 'libfilteraudio-git'
- 'hicolor-icon-theme'
- 'libdbus'
- 'libxext'
- 'libxrender'
- 'openal'
- 'tox-git'
- 'v4l-utils'
-)
+depends=('desktop-file-utils'
+ 'fontconfig'
+ 'libfilteraudio-git'
+ 'hicolor-icon-theme'
+ 'libdbus'
+ 'libxext'
+ 'libxrender'
+ 'openal'
+ 'tox-git'
+ 'v4l-utils')
makedepends=('git')
optdepends=('gtk2: GTK file picker')
-
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-
source=("${pkgname}::git+https://github.com/notsecure/uTox")
md5sums=('SKIP')
-
install="${pkgname}.install"
-pkgver()
-{
+pkgver() {
cd "${srcdir}/${pkgname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build()
-{
+build() {
cd "${srcdir}/${pkgname}"
make
}
-package()
-{
+package() {
cd "${srcdir}/${pkgname}"
make PREFIX=/usr DESTDIR="${pkgdir}" install
}