summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2016-12-09 20:31:10 +0100
committerBernhard Landauer2016-12-09 20:31:10 +0100
commit88c961f29f8bbac441ae257cafdec92add7b9315 (patch)
tree2e383d9c225d64e0aee08ee79e30e04db9a16ab8
parent8e21e37b85d8cfb70ab4ebaa2d46ed2813e96062 (diff)
downloadaur-88c961f29f8bbac441ae257cafdec92add7b9315.tar.gz
fix package, use official source
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d573a22a4578..4142f3ebb5de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Wed May 25 14:19:57 UTC 2016
+# Fri Dec 9 19:28:47 UTC 2016
pkgbase = utox-git
pkgdesc = Lightweight Tox client
- pkgver = 0.9.3.r7.g757b223
+ pkgver = 0.9.8.r338.ge1d0cf5
pkgrel = 1
- url = https://github.com/GrayHatter/uTox
+ url = https://github.com/uTox/uTox
arch = i686
arch = x86_64
arch = arm
@@ -12,6 +12,7 @@ pkgbase = utox-git
arch = armv7h
license = GPL3
makedepends = git
+ depends = c-toxcore
depends = desktop-file-utils
depends = fontconfig
depends = libfilteraudio-git
@@ -20,12 +21,11 @@ pkgbase = utox-git
depends = libxext
depends = libxrender
depends = openal
- depends = toxcore
depends = v4l-utils
optdepends = gtk3: GTK file picker
provides = utox
conflicts = utox
- source = utox-git::git+https://github.com/GrayHatter/uTox
+ source = utox-git::git+https://github.com/uTox/uTox
md5sums = SKIP
pkgname = utox-git
diff --git a/PKGBUILD b/PKGBUILD
index 431f683ca0a2..c9ebda60925a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Vlad M. <vlad@archlinux.net>
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
# Contributor: Madotsuki <madotsuki at cock dot li>
_pkgname=utox
-pkgname=utox-git
-pkgver=0.9.3.r7.g757b223
+pkgname=$_pkgname-git
+pkgver=0.9.8.r338.ge1d0cf5
pkgrel=1
pkgdesc='Lightweight Tox client'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-url='https://github.com/GrayHatter/uTox'
+url='https://github.com/uTox/uTox'
license=('GPL3')
-depends=('desktop-file-utils'
+depends=('c-toxcore'
+ 'desktop-file-utils'
'fontconfig'
'libfilteraudio-git'
'hicolor-icon-theme'
@@ -18,13 +19,12 @@ depends=('desktop-file-utils'
'libxext'
'libxrender'
'openal'
- 'toxcore'
'v4l-utils')
makedepends=('git')
optdepends=('gtk3: GTK file picker')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$pkgname::git+https://github.com/GrayHatter/uTox")
+source=("$pkgname::git+$url")
md5sums=('SKIP')
pkgver() {
@@ -34,6 +34,7 @@ pkgver() {
build() {
cd "$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}